Out of memory issues with Renoise with a specific song :C

I had a vocalist visit over the weekend, and for some reason had no end of problems with renoise. It got a bit embarrasing because we couldnt record vocals to the actual track :confused:

Crashes all the time, unable to “save as” and out of memory errors all the time.

Crashes occured throughout the 2 days, sometimes we got 15 mins without one. “unhandled exception in thread: Audio Salves”

In the end everything was recorded in Cubase.

When she left on Sunday I spent 5 hours whittling down the problem and eventually traced it to one sample. The song file is attached - if I press play, it crashes. Because of this - no ability to render as either.

Save as would not work, as well as print screen.

And…as you can see the song size is 44mb…how is it out of memory??

Hard to say what happens or happened here without seeing the song. Would you mind sharing it with us? Can also send it to us privately.

Did you used the 32 or 64 bit version of Renoise?

If it’s the 64 bit version it indeed is unlikely that you are running out of memory.

I guess the song uses a lot of plugins too? Maybe something got corrupted in the song, in Renoise or in some plugin the song uses - or some or more plugins are using a lot or memory for whatever reason.

Its 32 bit windows - I forgot to press attach file, sorry

So weird cos it’s never doen this before. I thought it might be NI Replika - which some people have issues with…so I came into work on Saturday to get the latest Replika update and graphics card drivers (which NI suggest to do).

I have a 64 bit system sitting (a while away) at home, maybe its time to do the switch.

I hope you can appreciate, this was a massive song file…so finding the one THING that was crashing it took a long time. I went through removing selected plugins, then non-native…then all.

The sample “chorus 1” was a vocal which I sliced up

Thanks for the details. That instrument got somehowcorrupted: It contains slices, but no (more) actual sample data.

Was this the result of a previous out of memory error? Or can you remember what else you did to/with that instrument before it got broken?

Would be easy to fix the broken song or instrument, but it’s of course more interesting how it got corrupted.

It was a chorus with 5 takes in… so I chopped it into 5 slices. I don’t recall exactly what happened, on Friday night it started crashing.

The track is fixed now (sample removed) but I’m still getting out of memory every time. And then sometimes unable to save as…

Will a reinstall help?

It was a chorus with 5 takes in… so I chopped it into 5 slices. I don’t recall exactly what happened, on Friday night it started crashing.

The track is fixed now (sample removed) but I’m still getting out of memory every time. And then sometimes unable to save as…

Will a reinstall help?

Could you send us a copy of this song, so we can have a look at this here?

Crashes here, too, on play. Then Renoise hangs while “Terminating…”