Pattern Loop Turns On When I Play From Position

How do i turn this off?
I think i asked this before except i wasn’t clear…
Cheers for any help in advance, this is reallllllllly bugging me.

You mean with the space? the space just continues the play-mode that you activated.

Right alt is pattern loop and Right ctrl is song-mode.
Press right ctrl first and then continue using the space bar to toggle.

are you using Linux version??

if so, I think you are facing with this fixed bug.

workaround: change/delete blockloop shortcut key.

Its THIS badboi, I’m using MAC…
Whenever i use it, it switches on this function (which it didnt used to before in previous versions)

I’m not sure how to change/delete the blockloop shortcut key. Although i don’t think it’s that, For me blockloop is one next door (to the right) of that key. That works fine.
I’ve searched preferences, i’m not used to editing the keys,

looks like that that key is associated with “Play Pattern from Current Line” action.

please go to
Edit => Preferences => keys => Trasport and change at your like.


Could you tell me what this loop pattern button ------

is called in the KEY INDEX so i can un assign it?
I still haven’t fixed this.
Have two functions just been assigned to the same key or something?

In the key assignment preferences, its under the Transport section and called “Toggle Loop Pattern”.

I’ve found it really useful to remap a whole slew of the keys to the way I work… one big one for me was remapping the “toggle follow pattern key” to the “~” key. This way its one key stroke to stop the screen from following he playhead and be able to edit easily while the song is playing. I’m on MAC primarily too, and this function is by default mapped to “command+ =(numpad)” thats just really awkward for a function I use all the time.

A lot of the default mappings are too many key combos to remember offhand (IMHO), so I’ve been remapping the things I use most to single keystrokes.

I have changed my buttons from default slightly so can’t remember exactly what it is but I do know there is no button set as default to toggle this. Out of the Right hand Alt Gr, Ctrl and Shift one of them starts playing with Lopp Pattern enabled, one with it disabled. I prefer a button to toggle it on and off so changed this a while back.