Pattern looping around when editing

Ok, here’s another noob question, should be obvious but i can’t find it :(

So, i’ve disabled pattern looping around when moving the cursor (at least top/bottom) – but how do i disable looping back to the top of the pattern when adding a note on the last row?* It’s annoying!!

*or near the end of the pattern, if the cursor step value covers the jump to the last row & back to the top

I think KMaki’s Edit Step Tweaks fix this (on the tools site)
Otherwise it should be as simple as pressing Shift+ScrollLock (it’s one of the togglebuttons just below the pattern editor, 2nd from the left)

Ah, if I understood correctly, I’m afraid it does not… :(/>/>/>/> Cursor behaviour when entering notes in pattern is AFAIK out of the lua-tool scope, if one leaves out some really, REALLY hacky ways of dealing with this. (Observing for notes added, replacing cursor after it has jumped.)
–just thought of another hacky way to deal with this - setting edit step temporarily to zero when in range for a out of bounds stepjump. Won’t work 100% either. (But I’m actually going to try this!)(Tried, won’t work. But there’s another hardcore method maybe…?)(nope. This feature done in lua coding is a dead-end afaik).


…maybe this thread should be moved to the ideas/feature-requests board then…

When first using Renoise this really bothered me, I’ve since gotten used to it. But it would be very nice to have an option to disable it.

I now understand what delt means… @delt: yes it’s impossible :(. I don’t mind it though really, just like you I always have the function turned off because on seems to trigger even more ( :P) unexpected behaviour.