Pattern Order - Renumber


how I switch off automatic renumber patterns in pattern order on add or duplicate pattern? (it’s very stupid for me, becouse I lose hidden patterns from other old modules - .IT .MOD)

And why it do this? Praclically if pattern 0 is in ordered at position 0 and pattern 1 is at pos. 1, so we needn’t pattern order… :D (joke - of course, but almost it can be…)

Thx and get on good work!

PS: I have in old .IT base pattern 0 (he is hidden - not in pattern order). Song started of pattern 10… If I in Renoise 2.8 want odd new pattern - I’m in black hole… :D (i’m sorry for my english)

Right click on the Sequence and untick Keep Sequence Sorted.

I believe this setting is saved per song though, so if Renoise is opening modules made in other programs with this setting set this might be something that needs addressing by the Devs.

Also note patterns not in the Sequence should not be lost, but appended to the end with a single empty module gap. So if the highest number pattern in your sequence was 20, then 21 should be blank and 22 and upwards should be the patterns with data but not used.

Many thanks! I look for in Preferences… OMG… I’m stupid… :D