Pitch Bend affecting all channels on VSTis

I would like to use VST aliases where you can use different MIDI channels for each instrument patch/part within one single VSTi instance. This is simple to set up and saves lots of memory and vastly improve load/save times.

But I have developed a bad habit of always duplicating VSTis as a completely new instance since there seems to be limitations when it comes to Pitch Bend , volume etc.

For example, the pitch bend bends ALL patches in that VSTi, not only the channel associated with the current instrument (slot). Same goes for volume I think and probably some other stuff. This makes the VST aliases practically unusable for me at least.

If I’m doing it all wrong, please let me know how to deal with this issue.

I made some quick searches here on the forum but could not find anything on this particular case.


EDIT: Pitch Bend actually worked as intended, weird since I tried just before posting :confused:

Volume/level kind of works. If you control the part level (if available) via for example CC 7 it is possible to control the volume individually for each MIDI channel. If you however use Track volume or Send Device, it will affect all parts which is a pity since I often want to control the level including the FX chain, not only the sound source. Using Send device for ducking etc. will make it hard to get around the problem.

Well, I’ll see how far these new discoveries affect my workflow.

I think that may depend on the vst, does it work in other DAWs?

I haven’t tested other DAWs but I think the behavior with the volume is the same with all VSTs I have tried.

If I’m doing it all wrong, please let me know how to deal with this issue.

It would be helpful to know which VST(s) you’re working with here, and maybe even get a small example XRNS file from you, to see what you’ve managed so far?

When working with multi-timbral plugins, keep in mind that you will typically also want to assign/route each of the plugin’s audio outputs to a separate track in Renoise, in order to have full control over each voice.

Thanks for the tip dblue, that seems to be the way to do it!

I wasn’t aware of the unexpanded Audio Routing panel until now.

At first I couldn’t get it to work although I set up everything correctly. What I also needed to do was to “Initialize Multi” in Omnisphere which is a bit strange since you clear your multi settings…

Ah, well I’ll see if it works in a real scenario without initializing and other crazy stuff tonight.

Thanks again.

EDIT: it seems to work also after restarting Renoise and load a song, SUCCESS!!