Plugin Delay Compensation

Hi Everyone.

I’m brand new to renoise, and in fact to making music again after a 10ish year break. Loving it so far.

I have a question about Plugin Delay Compensation - Ive read some stuff about convolution plugins and the like, I just wanted more of a general idea of when it should be on and when it should be off. It seems like it’s on by default. I happily made my first track - but have noticed that there’s some heavy input lag when PDL is on. IF I do live input while its on renoise adds some delay to the track too. If I turn it off, it all seems fine, but some of the tracks I’ve put in in the non live way (using built in renoise synths) then seem to go out of time.

Should I just leave it foo until I need it? What’s the deal.


Are you sure the delay is from pdc? The sound settings usually define some latency, that will always be there, and has nothing to do with pdc. This is normal, you will need to tune your computer to push the basic latency very low for live usage.

If you have big lag with pdc, try finding the plugins causing it. Normal realtime use plugins usually won’t cause big delay, the convolver should be and will only involve delay that is in the impulse response or pre delay setting. some mastering plugins can impose delay (linear phase eq…), and for example the signal follower if you use lookahead, that is normal because it enables it to look into the future by delaying everything else. I don’t know of other renoise native plugins that could cause large delays. Are you using any VST plugin Or maybe you’ve stacked a crazy pile of simple plugins somewhere?

PDC is a big advantage keeping stuff tight and in sync. If you turn it off, the tracks with delays will still lag behind, but all other tracks will kick in at different times, pushing stuff out of sync. Each plugin, native or vst, might define its own delay.

It’s literally a case of - if I have it turned on - pressing a note on the keyboard has about a half second lag and the note gets entered with a value in the delay colum. running at about 25% CPU.

I only have 2 VST synths and a couple of EQ style plugins running at the time. Though I’ve really been kinda scattergun about it, I’ll be a bit more considered and pay attention to it in the future.

So you think it should just be left on?

OK so it turns out a one of the eq plugins had a maximise feature with lookahead, which was causing the problem. Turned that one plugin off and all back in sync.

PS - I was using the plugin in totally the wrong way and place - I’m aware of that, like I said… not really this most considered approach this time around!

Thanks for the direction.

It depends which plugins you use. Linear phase eqs and lookahead compressor/limiter can add quite some latency, they are thought for mixing and not for direct monitoring use.