Plugins drain CPU before they're used

Strange behaviour - pluigns (like Vital for example) drains CPU before they start to be using. I mean - I have for example 10 Vital instruments and after I load song, CPU is instantly go to 99.9% and song plays choppy. BUT - when I play them one by one - CPU usage decreasing (every instrument/plugin activation - when it starts playing) and remains at lower level after instruments ends playing.

Why is it 99.9% anyway if I see in system that IDLE process is about 70% at the same time?

CPU: i7-8700k @ 4.7 GHz

Happens on my i5-9600K as well sometimes, no clue what’s going on I just give it a break and let the dust settle :sweat_smile: … but it helped changing the Win10 power options to High Performance.

I have High Performance enabled and customized.

Renoise allows each plugin to consume the % CPU allocated for audio processing it needs. Therefore, if you have 10 Vital plugin windows (or any other) running, each one will consume a % that is added. To avoid this, go to the “Plugin Options” window and check the box “Auto suspend plugin when silent”.

image

Repeat this step for any plugin you want to “control” its idle audio processing.

1 Like

If it is a solution without any drawbacks, then why is not enabled by default?

If the cpu usage is higher while no audio than with audible audio, it most likely is a problem with denormal (veeeery small) floating point numbers. Those will cause the CPU to enter an “high precision” / extremely slow special processing mode, which totally messes up performance.

Maybe a workaround is to enable auto suspend then, but denormals can be considered as a bug and should be reported to the plugin vendor. So it might be good, if you really determine here which plugin is causing the problem, since it also can be any kind of fx processing plugin, too.

It even is possible that Vital is not the cause, although it seems so. Maybe Vital is just not outputting really a zero value on idle, so then it triggers some processing vst, which then could have a problem with denormals. An accurate test would be here to remove all fx, save the project under different name, reload it and check, if the problem still exists, etc.

If the cause is a processing fx, then a workaround might be to add a dithering plugin before the fx, so the noise floor never drops to denormal levels (which are insanely small, nobody needs any processing in that area).

Press Stop twice.

I was asking if there is an option to disable plugin when is not used, then why this option is not enabled by default?

And no - it’s not only Vital - I removed instruments one by one and Vital was most heavy of them all, but after I remove all instruments (and every removed instrument CPU usage drops a little), there was still over 20% CPU usage (plugins for effects are still there).

What is strange here that Task Manager shows 80% idle at the same time when Renoise shows 99,9% CPU usage. So there is plenty of CPU power left.

It is not enabled by default, because Taktik chooses the most compatible setting by default. auto-disabling might cause audio cutoffs with some plugins, or interfere with the plugin’s own mechanism. This really is a plugin problem, not a Renoise problem.

The Renoise meter can already show 99,9%, if only a single core is maxed out, it shows the peak value. The system task manager calculates in the average of all cores AFAIK.

I would say Renoise isn’t handling the CPU optimally.

I’m working on a song that if I turn off 40 of 45 tracks it still bogs down when pressing play after right-clicking the stop button, even when just playing snare and claps with reverb it consumes 92% of my 6 cores intel 9600k CPU with no other applications taking much CPU in taskbar.

I just tried turning off all tracks and have no sounds playing yet CPU is at 84%, this is not how it should work!?

10 minutes later and I can play my whole drumbus (18 tracks) at 66% CPU usage.

Hard to say, also my knowledge ends here. I guess only Taktik could say something valid here anymore…

But keep in mind that

  • The macos meter does not end at 100%, it ends at 100% * core amount.
  • The macos meter does show the average over a timeframe, so you can’t see any peaks
  • The Renoise meter shows the peak value of all cores. That means, if one core has 95% usage even only a short moment within the audio buffer time frame and all others only 20%, it will show 95%. Since only the “single core peak value” is interesting for not having dropouts.
  • Some plugins are poorly coded. For example VPS Avenger: It produces very high and short cpu spikes which can easily reach 100%, even while ridiculously simple operations. Esp. in the macos version. It never was fixed.
  • You can more accurately check a plugin for spikes with the Bitwig’s cpu meter, since it plots a quite fine graph over time and also peaks.
  • Some plugins may cause those denormal states. It is hard to say actually since I don’t know any way for an indicator here. Buzz had such denormal counters in its cpu usage statistics (really nice feature to sort out problematic plugins)
  • Could be also that Renoise is the reason here, but I would say it is way more likely that a plugin is the cause, since nothing really changed in Renoise multicore dsp processing since a decade or so, at least AFAIK

Ah, I thought you are using macos, but you are using Windows?

Yes I am on Windows and in this song I only use mainstream plugins from Arturia, Sylenth, Izotope, Native Instruments, Fabfilter and Soundtoys, so no obscure plugins.

I know I am on the edge of what my CPU can handle in this case, but I am at a point where I can no longer work on the song unless I remove something entirely as turning off tracks and plugins has no effect on CPU usage which is what I believe is suboptimal of Renoise.

This issue is obviously different from OP I just mention it as it’s CPU related.

@Garf

I have been dealing with 100% CPU in use many times.

If you still have 100% CPU after optimizing your plugins, break the song down:

  • render parts to new samples when there are lot of plugins or effect plugins with high CPU

optionally

  • make a mixdown of all tracks rendered out as sample *(with or without effects)
    and make a new mixing stems project.
  • disable send tracks and render the tracks as sample, then try a new mixdown project with sends

Optimize your plugins at first.

  • remove infinite release (this does mostly immediate 100% CPU in some plugins) to lower
    …in the Volume, Filter, LFO, other enveloppes, no infinite release times should be set.
  • lessen delay and reverb length / size (a long delay or reverb makes high CPU %)
  • set the number of voices to only the needed number instead of maximum

Also! Increase the Latency in Renoise. Low by default as it then responds fast buut it causes hickups below 150 ms when you have used many plugins (not only 1).
I mostly set 175 ms or even 200 ms of Latency on big projects…
menu Edit… Preferences… Audio… Latency (ms)

1 Like

Izotope has some weird behaving plugins e.g. that spectral shaper thing. Since you are on windows, you actually could install buzz and test those. Are you bridging any plugin? Try to disable the sandbox completely then, and replacing any 32bit plugin.

I agree though that Renoise still has room for multicore optimization, but it is a very complicated topic. I converted a bunch of songs to Bitwig, using the same fx and track amounts. In Bitwig, I never ever have to increase the audio latency, everyhing runs at 8ms/48khz fine, but the Renoise song counterpart often requires then 20ms or so.

I experienced similar lately as you are describing it, in some projects. Also the GUI is taking a lot of CPU power just to be refreshed all the time. If you use 4k, maybe try to rerun the project then at fullhd instead. fullhd is a quarter of the size of 4k.

So try some tests to nail down the actual problem a bit more. I think Taktik so far barely can find any useful information here. But I can’t speak for Taktik hehe

This might have no effect at all on CPU, at least turning off tracks. Not sure about turning off plugins, but at least the latency/PDC always is kept. The only valid test here is to remove the plugin.

1 Like

Turning off tracks and plugins does indeed not have much of an effect likely due to the PDC but it does give back some which can be meaningful, anyway that’s something that arguably need a solution else Renoise is kind of impossible to work with when you are close to maxing out.

How about a new “Bypass container” device that works like the doofer but has the ability to completely bypass / turn off everything inside … or add a Bypass button on the doofer.

Yes, that’s a good fix to finish arranging a song … can’t wait to upgrade CPU though :crazy_face: