Pop Sounds

Hello everybody!
I was lucky enough to find Renoise, as I have been a tracker user since 1989. I have imported a set of orchestral instruments through the VST plugin. I must admit they are quite memory consuming.

What happens is that some of the instruments appear with pop sounds at times. I have used various settings with ASIO and Direct Sound (including Latency levels), but still the pops don’t go away.

My system is:

Pentium D 3.2GHz (dual core)
2 GB RAM (4x512MB DDR2 PC2-4300U)
Soundblaster Audigy 4 (secondary sound card, I have the onboard disabled)
Asus P5WD2-E Premium motherboard

Can anyone give me a hand?

Thanks in advance guys!

Are the pops consistent? (they come back in a solid frequency)
Do you use samples or VSTI’s or both?
Can you trace back pops to samples only or do the VSTI’s pop?
If the samples pop, do they contain loops?
And do the loops pop?
If the VSTI’s pop do they support the samplerate you are using? (which sample rate are you using?)

The pops are consistent in certain parts of the song. It seems that when the specific instruments are in silence for a few seconds they come back up with a pop.

The looping instruments don’t have a pop sound at all. When I play or preview them (through pressing the “return” key) everything flows normal. When I do the full playback things get “poppy”!

The CPU usage of the module does not exceed 17% in some areas where pops appear. The maximum CPU load I have achieved was around 45%. And yes, all of the instruments are VSTs and they happen to consume an average of 1.4 GB of memory. This may sound a lot, but keep also in mind that the workstation I have renoise installed on is kept constantly off-line without any resident programs. I use it strictly for 3D Animation and Sound (and an occasional game from time to time). I do all my network (with resident programs) on my laptop.

Generally many of the VSTs have loops but they don’t pop through repetition. The sample rate I am using is 44100 the exact rate of all VSTs.

1.4GB… are they sampler VST’s?
If so do they use disk streaming option?
This might also be a cause… (live streaming samples from disk). Specially if they are being cached to the page-file which is pretty much funest… so take care you seriously have enough RAM for that and with your 2 GB i guess it looks alright, but XP consumes an amount and a lot of extra processes also consume their part so this makes the 1.4 pretty tight fitting if i may guess so.

Yes, they are samples VSTs, but they only load in RAM. If physical memory starts getting low I get a warning message. The total amount of memory consumed on my computer (I have two screens and I can monitor the task manager at all times) comes up to 1.8GB of physical memory, as Windows XP rarely goes above 270MB of memory consumption (I have no resident programs on that workstation and I keep everything to a minimal).

I even lowered the playback rate at 22050Hz, which forces the VSTs to load at a lower sample rate (thus occupying half the memory), but the problem was still apparent (but pops were kind of weaker due to frequency limitations).

So, I was thinking if it would be worthwhile to render the song and then just use a waveform editor to remove the pop sounds.

You mentioned the pops come up after long periods of silence. I’ve solved some VST pop situations by inserting note-offs for example when using chords with strings:

Without note-offs:

C-5 E-5 G-5

D-5 F-5 A-5

With note-offs (fixed popping):

C-5 E-5 G-5

D-5 F-5 A-5

Another situation where I remember getting pops from VSTs was when my tempo/bpm was being altered and the VST was trying to compensate for the changing bpm. Some VST do better with this than others. If this is the issue and the VST doesn’t like the bpm changes some VSTs give you the ability to override external bpm and set the value internally in the VST.

Thank you all for your replies! I will look into your suggestions. Still, I have noticed that even at the beginning of the module, when some violin instruments come in, they do a pop sound. And I do keep the bpm stable at 90. I’ll look into it tomorrow and come with a feedback! Again, thank you all for your support! :walkman:

If physical memory starts getting low and you get the warning message, Windows is already moving up contents of your data to the page-file to be sure to have enough free ram for processing. (Also Windows works with a threshold parameter to move RAM contents to your pagefile so it creates enough breathingspace for possible other running background tasks that need an available amount of free RAM besides Renoise)

Here is a good test:
Just remove some instruments from the popping song, not the instruments that pop, but at least a few instruments that take up a lot of memory to bring down memory consumption to little over 1GB.
Then save that song under a different name, close Renoise, restart it and load that song and see if it plays the song without pops.
If you don’t get “RAM low” warnings and you don’t notice pops in that case, your problem is related to lack of RAM.
If you still get pops, the cause may be something else.

Ok, I found some time yesterday to make another example work, pushing the computer just a tiny bit in several aspects and here are my conclusions:

1. Memory

There is logic in your words vvois, Windows is very well known for memory mismanagement and I’ve had my bad experiences even in 4 CPU / 4GB systems at work!
I loaded up around 12 VSTs with the total amount of memory not exceeding the 1.2 GB limit. I created a rich orcherstra pattern, enough to bring the cpu consumption up to 34%. There were no pops during playback, even though at some point the harp double-played itself (it was a somewhat more fast paced instrument), but that had nothing to do with Renoise, it happened the first time all the intrument memory banks were called to action at once and the effect was gone afterwards.

2. On and Off VSTs

Kaneel, you are right. Being a user of tracker programs for nearly 17 years, I was used to my Amiga, when one instrument “off-ed” another in the same channel. The same thing happened when I was composing with my MIDI. With VSTs though, I have seen that it can be up to the “wishes” of their native programming. I found it more useful to turn off each instrument just one line before entering the next, or at least put an “off” command at certain intervals in case the notes are too close to one another.

3. Notes

Sonicade, in one of my bigger modules, the first pops I get (3 at once) is at the very beginning, which I will have to blame the memory call procedures to put everything into action. I haven’t yet paid any specific attention if certain notes are causing those pops, but I will do so in the first opportunity.

Again guys, thank you very much! In the times we live in I had forgotten what it means to have a support system! :D