Portamento, mono MIDI


(Camper) #1

Hi,

I’ve been trying various ways of getting a piano roll MIDI editor going. Was experimenting with Polygrid and MIDILooper.

But they both seem to not get polyphonic data across in a way my mono track is picking it up. Even if I press the mono legato button it still gets the poly MIDI data through.

Also have tried the 0Gxx command but to no avail… Is there a way to preset Renoise to just go mono in these cases?

The other way I get somewhat decent results is to use another DAW which is not really tight “using real/virtual cables” real cable is best in my case.

Only to find if I export the MIDI file to hit the same problem of not being able to implement the 0Gxx command.

So i was wondering how to implement this command propperly? Where to put it to make it work?

Regards,


(danoise) #2

Renoise doesn’t have a mono track as such. Everything you put in a track is literally played back.
The “mono” option is strictly for while recording notes - to limit the number of simultaneous notes that are entered into the pattern.

I’m not familiar with Polygrid, but often, a instrument in monophonic mode will take the last arrived note and play that.
Any other note which is also active is suppressed, but might be activated when the last arrived note disappears.
In other words, the plugin is interpreting (potentially) polyphonic input and turning it into a single playing voice via some internal logic.

Renoise, being a tracker, has something similar to monophonic mode though - the NNA (new note action).
Unlike plugins, which does not have “note columns”, NNA takes advantage of this and uses it to chain notes situated in the same column together.

So, if you want to create a monophonic track in Renoise, it’s mostly a question of putting your notes in the same track, and
then defining a suitable NNA action and/or use Gxx commands to achieve what you want.

This is a complex subject, here’s a video explaining the NNA concept in more detail:


(Camper) #3

Ah yes, I see. So mono can be set but there’s no portamento, unless you mark it with 0Gxx. I found that works on one track to the next note.

Thanks for the reply!