Possible issue with Windows 11 when typing in text/numbers within VST/VSTi interface

I just set up a new machine and spotted a possible bug.
Renoise 3.4.2
Windows 11, Intel Core i7 12700k

When opening a VST/VSTi to its external editor (=its own window/interface) and then double clicking somewhere to type in parameters, Renoise keeps Keyboard Focus in the instrument list simultaneously. This causes the instrument to play out loud, while data is being typed in.

Steps to reproduce, expected / actual results:
Open a VSTi such as u-he Diva or a VST such as FabFilter Pro-Q. The same issue applies to both VST2 and VST3 versions.

-Click to open u-he Diva’s presets (inside its own interface) and search for a preset by typing something with the keyboard; each key press now also plays the synth out loud.

-Click to open FabFilter Pro-Q, double click to set a new EQ point - then instead of dragging with the mouse, double click to type in a value (Freq, Gain, Q) with the keyboard. Again, each key press also plays the sample or synth (which is currently selected in the instrument list - of course if nothing is selected there, nothing will play) - so if I type in 2.5dB, you will hear C# (2), D (.), F# (5).

What it -should- do is stay silent while typing in data and return to normal (audible) mode after having pressed enter (finished typing in).

In the lower left-hand corner of the VSTi editor window in this image from the Manual, there is a small checkbox with the label “enable keyboard” to the right of it. Is this checked or unchecked when you notice this behavior in Renoise? (The behavior you are seeing is the correct behavior if it is unchecked, and the opposite behavior that you would like to see is the behavior when it is checked)

Thank you Jesse, this did fix the issue I was having.

That checkbox was the very first thing I checked but I had my logic on backwards: I had made sure that it is -un- checked! (thinking that ‘keyboard’ stands for ‘enable playing/hearing notes using the keyboard’ when it was in fact the opposite) so, my bad.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.