[???] Possible Pitch Bend Command Bug?


I’ve been running into this weird “bug” - or well… I am wondering whether it actually is a bug. It’s a bit annoying though and quickly skimming through the various topics, I didn’t see this come up so:


  • Load this RNS file into Renoise. It uses the predator synth but you don’t need it to reproduce the error.
  • Simply click the little + to Append a Note Column.
  • See what happens to the various parameters of the channel and press play to see the parameters change even more

Apparently, when you expand the channel by adding a column, Renoise assumes that one of the commands for pitch bending is actually a “reset all parameters” command. However, it does not set the parameters to a specific setting - it seems.

This bug only occurs when you enter pitch bend codes lower than C10D00

Maybe I’m missing something here and someone would like to elaborate on this but this comes across like an error.

Sorry for the late reply.

I’ve tested this and could not find any “reset all parameters” issues here. After and before adding new note columns, Renoise only sends out pitch commands to the VST?

But maybe I did not understood you. Could you please explain what you mean with:

Basically, the problem starts to occur when you append a note column on a track that has pitch bending.

Whenever I do this and use pitch bend commands, eventually Renoise starts to act them out on other parameters. It even turns off plugins on that particular channel altogether. It also changes sliders (often setting them to their lowest setting) and more stuff like that.

Today, I think I actually found a bit of a work-around for the problem… or well, it seems to “solve” the problem somewhat. When I “get rid” of the effects column (by pressing the - symbol/delete the last effects column) and then add it again (by pressing the +), the problem does not seem to continue.

I hope this clarifies my previous explanation a bit. If it does not, I’ll upload some screenshots or something. :)

What i think that is the problem is that when you add a notecolumn then the panning column gets detached from the effect column because the MIDI command setting is then no longer the last note-column so the effect column is now affecting the DSP’s instead of the midi information of the specific instrument.
You can also disable the song-follow (scroll-lock key) so that effect parameters are no longer directly applied to your DSP’s when you are moviing around in the pattern making changes does this also resolves your issue?

It might be related to your first suggestion.

With the speed my patterns go, you don’t even want to turn on song-follow. Trust me, it’s a bug - not an issue I’m causing. ;)

Just download the module I uploaded and see for yourself - it’s very easy to replicate the issue.