Problem Saving Songs Since Upgrading To Version 2.7

Hello,

I have been using Renoise since version 2.0 and it always worked fine. But since I upgraded to the 2.7.0 final a few days ago, I often have to try saving my songs twice before it’s working. I always get this error message:

“Saving failed with the error:
The song was successfully saved, but could not be moved to its final destination:
I:…
Please make sure there is enough free space on the disk.”

I have more than enough space on my HD. It seems to happen mostly when saving during playback and with files which have big samples (~20 Mb).

Edit: I am using XP 32 bits Media Center edition with SP3.

Thanks!

I don’t know, but maybe there is not enough space in the WinXP virtual memory or RAM perhaps? Just a wild guess, i really have no idea if that should be a problem.
It’s possible to increase the virtual memory, could be worth a try.

Thanks for the suggestion. The virtual memory seems to work fine as I don’t have any problems with other software and it’s already maxed out. It seems to be specific to Renoise 2.7 because I tested 2.6.1 again and didn’t encounter any problems.
My songs are pretty small, about 25 Mb.

maybe the log file has some more evidences of the problem:

Help => Show the log file

Thanks for the suggestion. Just checked the log file and I couldn’t find more information. Here is the log:

Application: Saving ‘Silverblade.xrns’…

Exception: The song was successfully saved, but could not be moved to its final destination:
‘I:\Music\Renoise\Songs\Silverblade.xrns.tmp’ -> ‘I:\Music\Renoise\Songs\Silverblade.xrns’.

Please make sure there is enough free space on the disk.

Error Message: Saving failed with the error:
Error Message: The song was successfully saved, but could not be moved to its final destination:
Error Message: ‘I:\Music\Renoise\Songs\Silverblade.xrns.tmp’ -> ‘I:\Music\Renoise\Songs\Silverblade.xrns’.
Error Message: Please make sure there is enough free space on the disk.

Application: ‘Silverblade.xrns’ could not be saved!

The error says I: is full. Is it?

What kind of disk is I:?

Network? Local? USB Key? […]

There was some code to speed up disk operations in 2.7. from what I remember. Could be a starting point.

I thought Renoise had started using the OS’s local Temp folder for saving (compressing) and copying over from there. That message implies it’s still doing it the old way, in the same place as the final file is going to exist, and thus you will need at least twice the space of the final saved song to be able to save it.

The disk isn’t full. There is still 83 Gigabytes of free space.
It is a local USB hard disk (Seagate GoFlex working with an USB 3.0 adapter on ExpressCard slot).

As I said, the second time I try saving the song, it works properly.

Perhaps te harddrive is doing something with the file before supplying access, you clearly have an access problem here, but why your drive is behaving like that is a mystery to me.

It’s even more a mystery that it seems to work fine now! I just tested on the same drive as well as on my internal HD and I had not a single error. Strange… I hope it will stay that way!

Mmmmh… It seems like yesterday was a lucky day, the problem is back today!

Have you tested your harddrive? (Fragmentation, errors, bad clusters, viruses etc.)

Do you have any virus scanners enabled, does the problem still happen when disabling it?
Maybe it somehow interrupts the overwrite/move process.

Well, I have been using Renoise these past few days and the problem is really inconsistent. One day I get it a lot, the next day everything is fine. I run weekly maintenance checks (defrag, virus, etc.) and my HD is fine. I haven’t been able to test disabling the anti-virus because the problem hasn’t happened since taktik posted his message. The one thing I am sure of is that I have encountered this problem with Renoise (2.7) only. Sorry I cannot be of more useful assistance since the inconsistency of the thing… If it gets back, I will do more testing.

Inconsistency is mostly related to other causes which are, or are not around.
If you don’t experience this always, we can somehow rule out Renoise itself, the only thing we need to figure out is:what is running on your system at the moment that you don’t experience the problem and what is the running the moment the problem pops up.
Or what are the humidity conditions (heat / moist other environmental stuff that can influence your hardware in subtile matters)

Yes, it might just be a coincidence that it happened with Renoise, especially if I am the only one who encountered this problem. I might have found the cause of the problem actually: Yadis! Backup, that I use to make real-time backup of some important files (including Renoise songs :)). It’s a great but quite buggy piece of software and it has erratic behaviours at times (like copying files it shouldn’t). I had to modify the Renoise profile when I noticed it wasn’t making backups anymore. It might have been interfering with Renoise, but I need more testing to make sure. I’ll post if the problem happens again and if I can’t find any solution. Thanks!

The same happens for me under Linux right now, apparently after I cleared my ~/.renoise directory for testing other bugs, which I mentioned in different threads.

Getting exactly the same message, but the file actually is sometimes saved under the proper name and all. Weird.

I am facing the same problem on Ubuntu 10.04. The file saves fine for the first few times, and starts showing the error after some time. There is plenty of space on tmp as well as the destination directory.

I have noticed that the file is saved after I delete the original file.

Just make sure no other process is accessing the file and locking it down for some reason, i can only think of that regarding the ponytear response where the culprit was found.
If you don’t have the exact same application running, perhaps some other anti-virus or anti-malware thingy is messing up Renoise writing to files properly.
Just take care the Renoise file extensions are filtered out of these kind of applications to watch over.

Hello!
I have the same problem on renoise 2.7.2 and linux 64 bit.

Although if I save it as another file, it will save normally!

Regards,
Decibelter