Problems Hosting Reason 6 With Rewire

I’ve just loaded up the pay what ya want version of Reason 6, and have run into a couple of issues using it as a Rewire slave.

First problem is (I think) that Renoise can’t use the Rewire bridge in 64 bit mode. I’ve worked around this by setting Reason to start in 32 bit mode, but it might be nice to someday be able to use 64 bit mode. At least it’d save other folks the hassle of figuring this out.

Second is that, once rewire is working, the Instrument MIDI Control and Instrument Automation DSPs no longer show any information about their linked instruments. They (or at least one of them) used to show named parameters available for control. Now it’s just a featureless wall of CC numbers. MIDI control does work, it’s just harder to see what you’re controlling.

Aside from that, audio and MIDI transmission seems to work fine.

About second problem, please check again the Instr. MIDI Control device. It should show the parameters list when you click the first column (by default it shows “Off”).

2422 reason6.png

It should, but it doesn’t. Aside from Off, all I have are the CC values:

2423 this_vile_trash.png

[quote=“mute, post:3, topic:33905”]
It should, but it doesn’t. Aside from Off, all I have are the CC values:

2423 this_vile_trash.png
Oooh, now I only can test this on 32bit Vista.
I think that your problem is related to 64bit OS… :(

Just chiming in with a useful link:

It’s a little guide written by another Renoise user that shows how to install/run Reason 6 in 32-bit mode so that it’s compatible with Renoise.

strange… i’m not having these issues

i’ve also installed reason 6 on my windows 7 x64 computer (actually two versions: 32-bit and 64-bit since 64-bit rewire would require that renoise also supports 64-bit rewire as a host)

the Instrument Automation DSPs don’t work with reason/rewire, only VST instruments as i understand it

but the Instrument MIDI Control works fine here, every parameter in e.g. kong shows up in that list

maybe these issues are caused by an overwritten (or not properly overwritten) rewire.dll or something?

Er, it might’ve helped to mention that I’m doing this on OS X Lion (10.7.2). Apparently this is a pretty me-specific problem, though, so I’ll try re-installing everything and see what that gets me.

Update: not much.

  • Removed both Reason and Renoise, and killed the rewire related stuff in /Library/Application Support/Propellerhead Software.
  • Installed Reason, set it up for 32 bit mode, ran it for the first time, and quit.
  • Installed Renoise, ran it for the first time (it installed its rewire magic), and quit.
  • Reopened Renoise. Added a rewire slave, Reason starts up.
  • Added a Malstrom in Reason.
  • Mapped an instrument in Renoise to the Malstrom. Added an Instr MIDI DSP.

No parameter names, just CCs.

Also tried installing in the opposite order, no difference.

Any ideas on how I might troubleshoot this further?

I’ve tried installing Reaper, but couldn’t find a way to list parameters at all. Everything seems to be by MIDI channel, but this is the first time I’ve used Reaper. Am I missing something, or is that how it is?

Is there another (free) Rewire master that might list the parameters?

It’d be nice to know whether I need to ask the Renoise or Reason devs to update their end of the Rewire bridge… although Renoise devs seem much more likely to get around to changing things. ;)

just to double check: you’re not using the demo version of renoise, right? (the demo is restricted in rewire)

Hmm, I think that even if he is using the demo version of renoise, he can use 2 stereo ReWire normaly.

Ableton Live demo can do this too, though the installer maybe a bit big file size…

Nope. Registered Renoise 2.7.2, registered Reason 6.0.1.

Okay, thanks for the instructional link. That would’ve taken more than a few minutes to figure out.

Live 8 (it’s 32 bit) does indeed show parameter names.

2438 ableton.png

And here’s the strange part… now Renoise does too. It didn’t yesterday. Technology is amazing!

Whatever happened, it worked, so thanks for your suggestions!

I’m not a developer so not sure too though, having installed Live’s ReWire might have some good influence to your system.
Anyway, it was good. :D