Program Hangs While Loading A File

not sure if this is a bug or what, but i’ve been working on a track and accidentally shut renoise down. (i had firefox running in the background and had closed that down but had maybe been a bit over enthusiastic with my clicking and also closed renoise down.) no problem i thought: i hadn’t long since saved the file and renoise didn’t ask if i wanted to save it before closing. however, when i restarted renoise and tried to reload the song file, the program just seems to hang. it says “loading song” on the bar at the bottom, but neither the patterns or the instruments seem to load, and if i minimise the window, it won’t reopen again.

at first i thought it might be down to some issue with the RAM or the processor (i have 2gb of RAM but my processor is only 1.3ghz; i’m running windows XP. ) when i checked the task manager, it seems to be using the memory normally (some 114,540K), but not the CPU. i’ve tried loading other files and they work ok: they usually push the CPU usage up to about 70% while loading in, but with this file, it never seems to go above 2 - 4%, and then only sporadically. there’s a fair few CPU intensive VSTi’s in there, but they’ve never caused this sort of problem before. the song file itself is only 768kb and it only occurs with this one file. anyone have any ideas what’s happening? :(

well, not really. but i have a few questions which might clear things up a bit (for potential helpers).

  1. have you tried turning it off and on again? :d (but seriously, try rebooting just to be “sure”.)
  2. most important i think: what vstis were/are you using in this song?
  3. how long have you waited for the song to load?
  4. not a question, but: you could try to reproduce the “bug” by creating some songs with those cpu-hungry vstis and tweak them around. take cpu intensive patches, dunno. and try adding one vsti at a time, so you can track down the problem to one specific vsti easier.

also, would you mind sharing the songfile? perhaps others can reproduce the error, allthough i’m not sure, as many maybe missing some of the plugins you used.

hm, and last but not least you could check the archiv’s integrity with winrar, 7zip or sumthing. perhaps the songfile got somehow damaged.

Any vst plugins in it?
What happens if you uncheck the vst folders in the preferences and then load your song, does it still hang?

yeah, i did reboot and try again. i’ve just tried again this morning and the same thing is happening.

anyway, i’ll try out your suggestions, see if anything helps.


ah! just tried this and the patterns load ok but it comes up with the plugins not found error. looks like there might be a problem with the VSTis then <_<

i’ll do a bit of fiddling to see if i can figure out which one it is exactly.

thanks again! B)

yeah: the problem was with karmaFX synth. i’ve just reloaded the two instances of that VSTi into the instrument slots and saved another copy. tried reloading it there and it works ok now.

thanks for your help everyone! :D