Question regarding MIDI input

Probably a new user issue, but e.g. I am recording in A2 notes from my synth (shows as A2 in the Instr. MIDI pane) but its recorded at A1 in the pattern, and shown as A1 when being sent back out MIDI. What have I missed?

Side question. My synth documents banks in msb,lsb format but I can’t seem to type that into the box (though it seems I can select the send order). Do I have to always manually multiply out to get the 14 bit bank number?

Ok, figured out this was a config weirdness with the synth.

Another question question, even though I’m adding new note lanes to my track when I try to step-record notes to that lane ( In ESC mode with cursor in right column ) when I press a MIDI key it’s going to the next track not the selected lane on the selected track. Have I missed a switch somewhere?


I think you have selected the line break at zero you must change the box to the number of lines you want to jump each time you press a key, I attach an imageCaptura de pantalla 2021-03-22 a las 12.17.44

Hi, for the A2 vs A1 note, on my side, midi is impacted by the octave selector in the tool bar, so maybe you can adjust this parameter when needed…

For the new notes lanes, if there’s no note off at the end of the first note, the tracker will account that the note is still playing and will allocate a new lane to preserve it (a new note embeds a note off) and will always do that with new note lanes. Consider adding note off if it’s possible.

edit: oh @eulogic answer seems better than mine… nevermind :wink:

Thanks, alas I don’t think either of these are the issue.

I had note step set to 1 when inputting my hats and 4 for the kick/snares (so predictable!).

I have also been pre-creating new lanes for the notes (note +) and positioning the cursor in that column.

Set like this, the typing keyboard correctly fills in the notes, but when I input with MIDI the notes are always going to the next track over.

Okay, I found it!

For some reason the MIDI Input device was set to Track 2 rather than current track. Not sure why, pretty sure I didn’t touch it.