Reaktor And Renoise

Being a huge reaktor fan it really bothers me that the sync between reaktor and renoise is really buggy .
I mostly make synths in reaktor with a built in stepsequencer , the reaktor pulse clock is synced to the host , but reaktor always misses the first step when renoise is set to a loop mode with more than 1 pattern ( 1 .2. 3 . 4. restart 1 = out of sync ) starts …I can only say that this behaviour is only happening in renoise ., unticking static buffers doesn’t help
Audiomulch and reaper no problem , I

it might be pdc related. what if you use a 8 bar count-in then loop pattern 2/5?

I never considered this. It sounds like gcd is referring to song position restarting on 1 instead of 0 when reset. This might be in the implementation of the reaktor sequencer.

Sometimes I get inaccurate timing between the end of the looped phrase and the start of the looped phrase in renoise. This doesn’t happen in the space between subsequent patterns, only when there’s a midi clock reset. Not a huge problem when rendering a song. Maybe it’s related?

There used to be a bug in reaktor’s song position object but it think it’s been fixed in one of the last couple updates. There’s an object in the user library and on the forums called songpos-fix which was used as a workaround for a while. You might want to look into this if you are using an older version of Reaktor.

I’ve attached the clock object I’m currently using. It takes the current song position, count length, and speed divisor and outputs a looping count stream. It’s been hacked together from various macros and a bit of it is in core (probably unnecessarily). Hope it helps!

the reaktor song position bug is fixed , yeah But I don’t use the song.pos. module . at least not for short 32 steps

I mostly just use …reaktor sync .clock module. ( 96 pulses ) send to frequency divider (divide by 6 = for 16 ths etc ) …send to seq.
I reset the frequency clock divider with a gate trigger in every renoise pattern ( mostly 128 steps long …) the missing sync is always at the verry last pattern when renoise goeseback to pattern 1 ( in loop mode )
@ pdc …reaktor does not need any pdc enabling when you untick ’ use static buffering ’ ( it is on by default …I always untick it …)

gentleclock: could you please upload a small XRNS and ENS so that we can have a deeper look into this?

@ phuture , yes when skipping the first pattern in the loop( pattern 0 ) thus looping etc …using the song pos .module …everything works fine
Seems that there is some kind of bug/anomalie how reaktor/renoise handles the verry first pattern in the song .
But …when rendering to selection from within thepattern ( no song rendering ) .in a lot of cases renoise , skips the first line
@ taktik , ill just upload a very simple ens. stepseq. make sure that every pattern has a note/gate ( this resets the reaktor clock sync ) .
Try rendering to selection …you’ll notice that it sometimes misses the first step

Do you only get this problem while rendering? Then it’s probably more a render problem and not a general “sync” issue after all?
Some plugins do tend to ignore the first notes after getting flushed/panic’ed, which does happen before rendering them. Probably need to find a solution for this then instead.

A small time-out before issueing the rendering or an imaginary pre-pattern of four lines and then cutting the small silence from the wave-file start afterwards?

no of course it doesn’t happen only whe’nnrendering , also when normal playback .But it seems that this is a bug in the reaktor song position module , been searching on the reaktor forum and there have been some workarounds but none of them are perfect .It’s funny cause standalone , reaktor is stable as a clock .I sometimes run reakor and renoise side by side ( each having their own soundcard driver ) perfect sync .

Just search “song position fix” in the user library. I think there’s a couple more, but that’s ^ the 1 I use.