Reaktor automation ID not working with Renoise automation device

OK, so,

Using Reaktor (5) as a VSTi, I would like to automate certain parameters in the ensemble “Limelite”. Problem is, the ones I’d like to control have an automation ID number higher than the 128 that Renoise’s automation device recognizes. I tried to change the automation IDs within Reaktor to accomodate, but they would not change. There are like 999 shown slots in the automation device, why can’t I simply identify the ID in Reaktor and then select the same number in automation device?

So is the automation device limited to the first 128? Or should there be a way to re-assign the ID in Reaktor?
What about some other work around?

Also, say I assign CC 18 to a knob and CC 19 to another knob, when I give the effect code for both to activate on the same line in the sequencer, only the first one triggers. I tried adding a note column in the same track but then it could not find the instrument (Reaktor VSTi) to send CC data to. But when I make a new track and set the second effect code on the same line (but different track), it works fine.

These may be two different problems, but the MIDI CC’s are driving me nuts when using a VSTi.

Any thoughts?

You can change the ID’s in reaktor.
Bring up the instrument properties. find the bit about device id’s, and theres a function that re-sorts them. You need to say “move instruments ids up” or something like that. Its kinda un-intuitive, but its all there.
Im at work so sorry about the crap advice.
Its all in the reaktor manual as well…

That’s the trick, I increased the max ID to what range I needed in the instrument’s property (not the parameter’s property). Awesome.