Reason + Pro Tools + Rewire Rc1

Hi Guys,

This is my first post in this forum but I’ve been lurking for weeks now. I’ve been using Renoise since shortly before the beta testing began for 2.1. I am a Pro Tools and Reason user and I was delighted to find the addition of Rewire support in this release. For the most part other than some transport control issues everything seemed okay up until RC1 which I just installed and tested.

I’m using Pro Tools as my Rewire master and slaving Renoise and Reason. The sessions I had done previously under beta 4 are now unable to load both Renoise and Reason as slaves simultaneously. Renoise starts first and when Reason tries to start the Rewire Engine is unavailable to it… Big problem for me. Another issue I have seen is that if you allow Renoise to go past the Beta splash screen before all of your plugs are done loading in Pro Tools they will be unavailable for use in Pro Tools.

2 biggies for me I thought I should let you know about.

Hello joeljynx,

Regarding your first problem:

Have you already tried to reboot your system. Sometimes, after a ReWire master or slave has crashed or something else bad has happened, the ReWire subsystem can no longer start connect. A reboot usually cures this.

Also, does this only happen in the songs you’ve made with the older Renoise betas, or does this now also happen when stating a new simple project in Protools with just Renoise & Reason slaved?

Is this OSX or Windows you run Protools & Renoise on?

I’ve quickly tested running Renoise & Reason as slaves in Live, and this seems to work just fine here, so its at least no “common” problem. I will try to test this with Protools on Windows as well. Would be great if someone else here with Protools could help us testing this as well.

Regarding your second problem:

This sounds very strange. What kind of plugins are those? And what means “unavailable” exactly? That they are no longer found, or that they fail to start up in Protools?
Would again be nice if you could test this in a simple scenario, with a fresh project with just Renoise & a plugin, so we could try to replicate this problem here in order to find out what could exactly causes this…

Thanks for your reply.

I have not tried it starting with a fresh project, however when I remove Reason from the Pro Tools project, save it and then re-open Pro Tools and instantiate Reason again it works fine. However, the problem persists unless I remove the Reason instantiations before closing the session.

The plugins issue seems to be caused by Renoise and Pro Tools both trying to access my iLok simultaneously to validate the plugins. Hence when I wait for Pro Tools to finish loading and authorizing my plugins before proceeding from the Beta splash screen everything goes smoothly. This could be a major issue once the release goes non-beta and the splash screen doesn’t stall Renoise from loading.

I will try starting from a fresh project this weekend and let you know the results.

Windows XP, Pro Tools 8, Reason 4, Waves Mercury v 6


Hello Joel,

I’ve tested the Reason issue here with Protools LE 7.3, but so far could not replicate this. Would be great if you could send me (taktik renoise com) or attach the protools project you are working on. Probably I can replicate it this way.

Regarding the iLock problem:
Make sure you don’t use a template song in Renoise: a song that loads up by default in Renoise when its starting and thuse loads some plugins.
Also go to the Renoise preferences, “Plugs/Misc” and disable the “Scan for new plugins on startup” option. This will avoid that Renoise opens up the waves plugins (and the iLock) while starting up…

Hi man, I just had the reg version of renoise, and I’d like to use in slave with a master protools. problem : no instrument insert for renoise application in protools.
I’ve try to launch first PT then ReNoise and I hope it asked me to use in rewire but nothing happens…
You’re the only one I found who speaks to rewire protools and renoise, and so I hope you still are “in da place”.

That is because Renoise does not export Instruments simply because it can have only one or two dedicated MIDI inputs for all instruments.
As Renoise instruments cannot be bound to a specific MIDI control device, they cannot be exported either because that kind of support is required for this to work with ReWire.
It looks like i misread your question… Renoise does not show as ReWire instrument in Protools right?
But if Renoise does not detects Protools as running master, it sounds like ReWire for Protools is not properly installed.

Ok I’ll try to find rewire module for ProTools, thks for your answer