Recording Audio In Live, While Slaved To Renoise


So the main reason I was really happy about the ReWire thing, was that I can now use an external application to arrange long sections of audio and play them back along side the programmed stuff in Renoise.

I know this can be done with EnergyXT, but I really wanted to use something I was familiar with; ideally Reaper.

Well, Reaper is not working for me with ReWire and Renoise at the moment, so I got Ableton to work nicely (with a few small issues, admittedly).

OK, so now I want to be able to record a long audio sequence into Ableton Live, using my Microphone, but when Ableton is set to Slave, all Audio inputting is controlled by the Master…

How would I record audio into Ableton through Renoise? I am hoping there is a way to do this…

Not possible I’m afraid.
The master control the soundcard.

Some plugins can help you transport the stream from one app to another.
But then again Ableton Live do not support VST’s when used as slave.
So you must pretty much record in renoise and then import the recording into Live.
Or do the opposite and use Live as master and renoise as slave.

Using Renoise as slave is the simplest solution, works both with Reaper and Ableton. If you need to use Renoise as master you could record using TapeIt vst, and then drag and drop into Ableton, which at least saves you the trouble of saving/importing a file.

Thanks guys.

Yeah, I figured that would be the case.

Ableton seems to be the most stable partner for Renoise at the moment. I am having no joy what-so-ever with Reaper.

Even Ableton seems temperamental though.

Thanks for the input.

Yes, unfortunately there are lots of problems with Reaper as slave or master, but I’ve already contacted them to get that sorted out. These are not just Renoise problems, but general problems in Reaper so its quite likely that this gets fixed sooner or later.

And as said in the other topics: If Reaper as slave still doesn’t spit out any sound, then make sure you are using the latest Reaper version. Reaper versions <= 2.5.5 do not work at all in Renoise.


For the record;

Renoise Master; Reaper registers, but sound is just clicks and pops.

Reaper Master; Nothing. Renoise doesn’t even register.


Yes, as said before: that happens with old Reaper versions - Reaper versions <= 2.5.5.

Please try the following: Click on any track in Reaper, then hit the small “FX” button in the track panel to add a new FX. Then select ReWire → Renoise and Renoise should start to run and auto connect as slave.

ReWire is activated in all the avilable ReWire application most of the time in two different ways:

  1. Either via track routing - you select the ReWire Slave just like a new Channel of Your Soundcard (for example Live, Logic, Cubase)
  2. Or as FX (for example Reaper, Fruity Loops)

Thanks again.

I have tried the technique you suggested for using Reaper as a master, but when I select the FX button, there is no option for ReWire…

Sorry to be a pain, but this isn’t working for me! Don’t mean to take all your time up with silly questions like this.

You probably won’t see rewire in the list if any other hosts are running.
Close all programs. Then start Reaper. You should then see the rewire in the fx list.

Then probably you’ve disabled (by accident, whatever) ReWire in Reapers Preferences? Reaper → Preferences → Plugins → ReWire Mixer Support

Yes, good point. Try restarting or killing all half dead audio programs. I forgot that you also have a problem with Renoise not closing correctly.

Psyj; You are correct sir!!

Ah, this ReWiring stuff really needs a solid set of instructions writing!

So, to update then;

Reaper as Master DOES work with Renoise. Sorry for the hassle. Your work, Taktik, is superb.