Redux won't show up in Logic Pro. Tried a lot (EDIT: SOLVED, SOLUTION INSIDE)

I tried multiple things but I just can’t get the AU component to show up. The first time I added it it said “cannot open” and I figured it was because of the license. So I re-installed and now it shows as “validated and openable” but I don’t see it in the list of Audio Unit plugins anywhere.

MacBook Air (M1, 2020)

I just tried it in Reaper and it does show up under AUi and can be opened fine.

When I go to Plugin Manager back in Logic I see that Renoise is listed, it says it is fully validated and open, but I don’t see it in the dropdown when I want to add an Instrument to a track. I do not see "Renoise: in the list of developers. When I rescan that particular plugin, I see that it ends by saying “Updating AU properties…” and I can’t tell if it’s stuck or if that’s just the last line of the process. It does not proceed once it reaches that point.

this is what it looks like:
image

Anyway thanks for any help.

Here is the solution. It seems to be an issue with Logic and the caching system on Mac.

You basically can solve it by following these specific directions. Renoise is now showing up in my dropdown perfectly fine after following this specifically:

image

now to make some fast beats