Render is wrong - why?

It’s EntropyEQ plugin, kind of EQ but with extra feature. It’s not something unusual or strange.

And something in Renoise render triggers this plugin every pattern (only when rendering, not while playing). I have the same sound parameters for playing and rendering.

I prefer to get answer form someone who may fix this bug instead of trying to explain why this bug may exists. I know that there is a bug, I don’t need to learn how to made workaround, I am trying to made Renoise better by reporting that bug.

1 Like

Maybe this VST has a bug?
Try in a free DAW…

Have you changed any of the “Plugin Compatibility” settings for this plugin? Especially the auto-suspend option, if enabled. (Looking at this plugin just now, I would definitely look check the compatibility options, starting with auto-suspend. I have a few "harmonic/noise/saturation plugins that simply do not behave correctly when auto suspend is enabled, for whatever reason)

If you haven’t tried enabling/disabling any of these options, go ahead and try them one at a time and render after enabling/disabling each one. One of them may solve your problem. Even if it doesn’t, knowing that known of them helped may give insight to anyone more knowledgeable about plugins that may view this thread.

Wait, are you rendering to MP3? Just looked closer at your attached screenshots. Does this also occur when rendering to WAV? Are you dithering and/or noise shaping? This information may be as important as what I posted above.

No, I render to WAV, but I am fast enough and have fast tools to convert everything in seconds, upload to my own server (I also do not convert directly to FTP) and prepare link. :slight_smile:


Thank you for your previous suggestion!
After few tries, I discover that enabling “Use static processing buffers” solve issue with this plugin.

Is possible to assign specific settings to plugin in general? If I must remember every plugin settings in Renoise, then it may be a little complicated later to setup everything right.

You don’t have to remember these settings as they are stored automatically

Yes, in song, but I mean - for plugin in general.

I just tested the settings in Plugin options and “Use static processing bufferes” and “Can run in multi processor environments” will be remembered in general but the “Auto suspend plugin when silent” checkbox don’t it’s not even stored with the song template which is a bit strange?

I can’t confirm that. It works ever since.

Huh… really!? Then I’ll report it as a bug because that setting isn’t stored here, wonder how that can be… I just tried again with both Sylenth and Spire and the setting isn’t remember on these plugins.

Ok, I also checked Sylenth1, in this case you’re right, the information is not getting stored. But this is the first time I’ve seen this. If you check this for example with SIDizer it works flawlessly. It seems that it depends on the plugin if it works or not. But don’t ask me why, I don’t have a clue.

Checked Serum, too. It doesn’t work, the information is lost after reloading the plugin. So yeah, obviously there’s a problem. Luckily I haven’t had issues like XTD until this day.

I don’t use Sylenth or Spire, but with SonicCharge, Tokyo Dawn Records, Voxengo, Plug&Mix, Freakshow Industries, Sugar Bytes, Kilohearts, Kazrog, Inear Display, Glitchmachines, AudioThing, Alpha Forever, Black Rooster Audio, BABY Audio, Audio Damage, D16, Illformed, Initial Audio, Klanghelm, NewSonicArts, Puremagnetik, Inertia Sound Systems, and Youlean plugins all settings are recalled correctly.

@Garf @TNT Are you using VST2 or VST3 versions of the plugins you tested? Maybe drop a bug report post in the proper category.

It does work with VST FX like Voxengo Span and Illformed Glitch2 but not any of the VSTi I’ve tried which now include Massive and Arturia Pigments 3, maybe it’s plugin specific or something else, anyway Taktik is tagged in a thread about it maybe he’ll provide an explanation.

VST2 all the way. I’m pretty sure that I don’t own any VST3.

Anyway, I checked samples of all my VSTs. The informations about the VSTs are remembered by Renoise except Sylenth1, Serum and Omnisphere. If you reload one of these three the information is lost, no more checkmark at “auto suspend plugin when silent”. But if you checked “use static processing buffers” it will be remembered. Everything else works fine.

As a workaround, save the song, after you enabled auto-suspend. It should be enabled after reloading the song.

Nope, it doesn’t work that way.

Strange, works here. Is the fat button “auto suspend” in the instrument settings enabled?

You mean the box next to “CPU usage”? Yes, it is. But there’s no checkmark anymore at “auto suspend plugin when silent” within the plugin options. But as I said, in my case this behavior only appears with Sylenth1, Serum and Omnisphere, everything else works as expected.

If the box is enabled, the auto suspend should work, also for omnisphere. Did you really check above if the plugin goes to “suspended”? The box is the song’s auto-suspend, which still is saved. The checkbox is the plugin database auto-suspend setting, which isn’t saved anymore. Maybe that is the case for a longer time now? But since you still can save it to your song, it shouldn’t be such a problem.

I never had any problems, I just checked for XTD and Garf if the checkmark at “auto suspend plugin when silent” disappears or not after reloading the plugin, which is the case. And this checkmark is always getting saved except with Sylenth1, Serum and Omnisphere. So if these informations are getting saved with all plugins except a few, there has to be something wrong, right?

1 Like