Render Pattern to Sample increases volume - Why?

When i render a pattern to sample it renders a much higher volume than it should. It’s not clipping anywhere, yet my rendered sample is clearly clipping.

Could seem like it adds the send tracks on top of the master or something, i don’t know?

Maybe you have your master volume turned down?

I even put a gainer at -6 db in front of the master post volume, still render clips. Hmmm, maybe some vst might have routed the sound to the wrong place or something?

Now i found it does not even record the reverb plugin i automated in the master track, it sounds completely different at playback than when rendered.

I can’t upload this file because it has grown too large, but i’ll see if i can make a clear example of the issue if i manage to recreate it.

When rendering from the pattern editor? Does this have anything to do with renoise auto-setting the rendered samples’ volume property to +6bd?

It renders the volume before the channel fader. So if you have the channel and/or master fader down, there’s a chance the level is above 0 db before the faders.

I tried to reproduce it without the shit load of vst’s i used in the original track, but wasn’t able to… It wasn’t just the volume, i rendered a pattern where i automated ‘oldschoolreverb’ from zero wetness to full and it wasn’t even audible in the render. It might be just some vsts that messes up, i don’t know.

It’s important to keep in mind that the “Render X To Sample” functions do not include the master DSP chain.

The idea behind this is to avoid doubling any master effects, since you’ll most likely play the rendered/frozen sample back through the master track anyway.

Your master pre and post volume could be set to -INF dB and it still wouldn’t matter: The result from “Render Pattern To Sample” is going to be whatever loud-ass noise came spewing out of the tracks before it reached the master :slight_smile:

Nevertheless, if you think you’ve found a problem and you can manage to reproduce it, please share an XRNS with us.

It’s important to keep in mind that the “Render X To Sample” functions do not include the master DSP chain.

Yeah that pretty much explains it i believe. :blush:

I haven’t been using “render to pattern” before really, maybe tried it once or twice. I assumed that when you right click the master track and select “render pattern to sample” it would include the master. I see your reasoning for not making it so, but i don’t think it’s very obvious.

I also could swear i heard a huge difference when i turned off the vsts i loaded in the master track, which sort of confirmed my assumption, but i guess i must have changed something else too…

Some more things you might want to know , and will save you some headscratching.
If you take two exact same samples , first one with a distortion device on it’s channel .
The second one with the dist.device on it’s
The results will sound different because first example applies -6db pre fader.
The second example does not applie a -6db on it’s instr.eff.lane…thus the dist.device
receives a louder input .