Render Selection To Sample

Load up a VSTi - play a few notes. Select the notes and Render Selection to Sample. It plays and records and everything seems OK - but there is not sample data in the sample slot. Gets lost somewhere. Any ideas fellas??

Thats strange.
You do see that it is making sound while rendering?
What if you use only samples and not vsti’s?

If I remember correctly Renoise do make a temp file when rendering that is then imported to the sampleslot (I might be wrong, as this might only be true for recording sample). But anyway, check if harddrive or ram is full?

HD or RAM is definitly not maxed out, not even close. I tried to render with samples as well, no cigar there either. This is really strange yes, it is one of the things I use the most - and it has always worked for me.

Hmmmmm!!???

Just to be sure, you get no sample data at all?
Empty sampleslot and no “Rendered Selection 01” name for the slot either?
Or do you get a silent sample?
If the latter, is it a long or very short silent sample?

You could also try to backup your renoise config files, then delete them and restart Renoise.
I have no idea if that helps though…

You don’t happen to have one of the older 2.5 betas to test with?

Damnit! I tried with 2.1 - and it did not work there either. I am on a laptop with whatever soundcard comes with it. When it renders, the volume bars moves, and I get that last decaying sound when it is done rendering as I usually does. The sample it records is silent, no data - however - it is as long as I make it to be. So it is actually recording, just not the sound.

This is killing me :confused:

Where are the config files btw? I am on Win7.

Are you sure that the selection you render is actually also routing output to that track?
e.g.:If you have a send-device with mute source on the track you have your selection in, you get nothing ;)

Please try also downloading the registered versions again. If something (a virus for example) modifies the Renoise.exe, rendering will result into silent files.

I have removed the old installs… and re-installed. Same problem. Where are the config files located? I cant seem to find them. I should probably delete those too.

This is one really has me baffled :confused:

Config files supposed to be in the \documents and settings[username]\application data\renoise
Simply add a new folder like backup and move everything in there to that folder.

There is no Documents and Settings in Win 7. There is a folder called users. So I looked there. But no Application Data folder. What is the exact name of the config file??

Its hidden by default. Renoise -> Help -> “Show Log file…” will open the folder with the preferences files.

I doubt this is a config issue though. Could you please try to disable all extra apps like virus scanners, then again download Renoise from the backstage and try this out again? Probably your virus checker blocks some operations that renoise needs to render.

Ok. thanks guys! Must have been something blocking on my computer. I went nuts and re-installed Windows on the laptop - now all works fine. This time without Norton which I suspect was the culprit as it seems to intefer with just about everything I do :)