Rendering synthmaster2 VST starts not at beginning/buffer


maybe this was already mentioned… If I render a song, sometimes it will not start at the very beginning of the starting point, instead the first note is somehow shortened… Don’t know if this only happens in non realtime mode.

The second problem I realized is that very often I can hear some audio buffer content of the last rendering / the end of the song on the next rendering at the beginning (although the song has enough time to fadeout completely). Would it be possible that the devs can flush all audio buffers first, before rendering starts?

I workaround the second point by start to play the song first and wait until all audio is released… But that’s quite annoying if rendering a lot of times. Can you fix it, please?

Maybe the second problem has the same cause as the first…

I’ve noticed both of these before, certainly the second.

Regarding the first problem, this happens with synthmaster2 vst. Maybe this a synthmaster related problem, some buggy muting / cpu saving code? Tried dexed in comparison, dexed does start normally. Also tried different vst renoise settings, auto mute on/off etc… no change.

The first problem also happens with Zebra. I just tried gazillion different options and none of them worked. In the end I tried using plugin grabber to bypass this but out of 3 notes in the pattern it only sees one to export and then when I export it, it sounds as if it came from a NES game. Ouch! It looks like the whole rendering engine is a mess. I’m really trying to find a way with Renoise because the workflow is divine in it but it’s my third day with it and problems are beginning to pile up pretty quickly :frowning:

Ok so for people who also have this problem and have stumbled upon this thread (np. do Ciebie Jurek): this is a known problem, there even was a thread on KVR about this and Urs himself made a special build of Zebra to fix it (which worked). That fix deleted some part of code though and nobody reported if this fix didn’t mess up something else long-term. Aaaand the links are dead. However, there are 2 solutions to this messing up of the first note problem. For me, only the second one worked, but there are reports of the first one working too.

1. Instrument Settings (lower panel) -> disable Auto suspend (a button in the right side of the box), or click the ‘?’ button and in instrument options disable “auto suspend plugin when silent”

This is a workaround, unfortunately. Suspending plugins in big projects is probably a must even with a very powerful rig so this cripples workflow and forces to use workarounds (probably uber-bouncing on a regular basis and bye bye to stuff like Diva, Bazille, Aalto, Kaivo…).

2. Preferences -> Device Type -> not-ASIO

I have both ASIO4ALL and FL ASIO drivers. The latter were introduced by Image Line with FL Studio 12 and are very beneficial because they freely share audio among all sources without stopping playback, like with most ASIO drivers. Anyway, both messed up my sound and switching to Direct Soundsolved the issue. Going with this, if you switch to Direct Sound and it still doesn’t work, experiment with the drivers! Install new non-ASIO ones and if they fail, try different ASIO versions. Obviously, they can be a culprit. If you do and succeed with something else, please write about it so others can benefit :slight_smile: I was on the verge of getting rid of Renoise because I can’t imagine life without Zebra, but thank God they can work together :smiley:

PS. I tested Synthmaster to see if the same problem would occur but everything worked fine.