Rendering while using fxpansion Tremor omits first notes of other inst

I’ve ran into a very strange rendering bug when rendering a project which includes an instance of Tremor.

Basically what happens is that every instrument - except for Tremor - skips the first note it should play, everything that comes after that first note renders fine. This does not happen during normal use and isn’t affected by sandboxing, routing of Tremorchannels, DirectSound or ASIO or the time when Tremor or the other instruments start playing.

To illustrate this:
These notes

result in this rendered sample:

I’m running Renoise 2.8.1.

Have you tried toggling the “Needs static buffering” option in the dialog that is hidden under the Question mark button of the VST panel?
Also turning of autosuspend may help…

Thanks, but none of that resolved the problem.

Could you replicate it in normal use by quickly hitting the stop button twice (panic mode) right before playing the song?

Yes! Do you know the cause?

Double stop or panic mode resets the the plugin. When you render, Renoise also applies panic mode to reset all plugins. I suspect the plugin is reporting a false delay time which could cause this problem. And Renoise won’t be able to catch this with PDC.(PDC doesn’t work if the plugins are not honest about what delay-time they produce for buffering)
Only fix is to just add a small 4-line sized empty pattern to do the “prebuffering” for these kind of plugins.