Renoise 2.5.1 : Small Maintenance Update For Windows 7

We’ve just released a small maintenance update for Windows 7:
Renoise 2.5.1 fixes problems with UAC on Windows 7, with the latest security patches installed.

This update is only necessary if you got annoyed by “C:\ Location Not available. Access is denied” messages from Windows when running Renoise.

If you don’t got those messages, you don’t need to update from Renoise 2.5.0 final. Mac OSX and Linux builds only have been updated to set the version number to 2.5.1.

Songs saved with Renoise 2.5.1 can of course be opened in Renoise 2.5.0 and vice versa. This update !only! fixes the above mentioned UAC problems.

There seem to be more UAC related problems with audio apps in general on windows 7. With windows getting more and more restrictive, security wise, ReWire might often also neglect to work. If you have problems getting ReWire working on windows, try to disable UAC. When even this fails, try running the applications as administrator (right click -> Run as Administrator). From my personal experience, this seems to be the only way to get for example Reaper running as ReWire Slave or Master.

Anyone else having troubles with Sampletank 2.53 or PSP Nitro with this release?

  • I get a failed to initialize with ST2
  • The registration dialog comes up for PSP Nitro

Both work fine in renoise 2.1 and were working fine in 2.5 (will roll back to 2.5 if I can`t fix this).

win 7 64bit here.

edit: this is all IKmultimedia plugs .

I’ve had some issues with the psp plugs (reg window pops up) on w7 x64… they work, but registration didn’t seem to take. Then I started to run the host app as admin, and it all worked like a charm. No idea why, but it did :) This was in 2.5.

If you run your app as admin you will never have these problems. It remains similar to “Sudo” an app.
What i don’t know if installing your applications and plugins “as” admin would resolve running problems later.
It doesn’t seem that Windows 7 has a proper “system wide” install option like you have in Linux.

Application writers are getting more and more restricted to perform actions in temporary folders (which is not a bad thing) but it requires quite an adjustment from the user that some stuff ain’t working that easy out of the box anylonger.

i dont use windows 7 but xp,but i havent been able to use my psp plugs(vintage warmer 2 and nitro)in renoise for a long time,the registration pops up,but i cant register it.

i run all as administrator

EDIT:just re-downloadet them and now it autorizes fine :w00t:

Back on 2.50 now and IK plugs are recognised again.

As the others said: If you have some old plugins which neglect to register themself, then running Renoise once as admin will fix this. You only have to run them once as admin, not all the time as admin.

Alternatively, try updating your plugins to make sure they no longer try to write at places where they are not allowed to.

Ok, I just re-checked this as it didn`t seem to work the first time I tried. Seems fine now thanks, maybe needed a restart?

Edit: Change that: Now Voxengo Gliss EQ2 refuses to register atall…

Yeah, i had a similar problem with windows 7, and yeah, running whatever programme you are having problems with as admin seems to work(note, this doesn’t mean having an admin account, it means right clicking on the program’s icon, and selecting “run as admin”)

As I wrote a couple of posts above there is a difference to be an admin and running stuff in Admin Approval Mode.
The later is the same as “Run as Admin”, having an admin account is just basicly a supped up normal account where you get a “continue/cancel” popup (sometimes).

Edit: sorry, it was in the original thread that I wrote about admin approval mode :)

Running Windows 7 Pro x64 with no problems. Wonder why it works? Maybe i’ve changed some UAC settings?

UAC didn’t exist until Vista.

And Win7 came out after Vista so what’s your point?