Renoise 2.6 (Os X) - Flanger Make Some Problems

Hello, I have encountered this problem with latest renoise using internal flanger effect on sample-based audio loop: when setting delay to 0 ms, amount to -100% and feedback to 100%, Renoise shuts output from master output. It looks like some kind of internal clip mechanism is started that prevents output of a too loud signal from program. After some investigation, it seems that problem was caused not only by flange, but a plugin on master, Maximizer. If you need, I can upload a song.
Also, after automating flange filter cutoff parameter, and then going back to a start of a song, it seems like it it isn’t turned on until automatization kicks again in.

Please upload a song.

I’ve had the problem you mentioned, but it was always related to a VST.

Never mind. I can duplicate this. Without the maximizer.

You can double click the stop button to get your sound back (otherwise known as: Panic mode)

Not sure if this is a bug, or a feature, you don’t want to destroy your computer speakers with infinite feedback…

No problem, here it is… it’s using only one Audio Unit plugin…
renoise flange problem

can recreate but I’d say it’s not a bug but a mis-used plug-in.

100% feedback and very short delay, you are feeding back on itself and effectively causing it to create DC at the output. If you move Feedback down you will restore sound without having to Panic by clicking Stop twice.

Easy to reproduce:
New Song.
Load Sample, Play on first line.
Insert Flanger on that Track, set Feedback to 100%, set delay to a very low value (had it do so on anything before about 1.8ms)
Hit Play.
Brief noise and it does its thing, then full level DC output, which wont be cleared on a basic Stop as Effects continue after a normal Stop command.

I say leave it as is and expect people to be able to use effects responsibly.

^^^ This.

I am sorry, but I can’t agree with that. If you allow that small delay size with a feedback that can be set to 100%, it’s not user’s fault that flange has overloaded itself and than host output. It’s a problem of design and features. Plugin must have some ranges and boundaries that will shut itself, but not shut main application output. It could have highpass filter of high order after delay, or something similar to stop DC offset in itself.

It is the user’s fault, because it’s the user’s responsibility to use appropriate settings. If you set the feedback to 100% then what did you expect would happen?

Believe it or not, there are times when 100% feedback is desirable. People have been using it for synthesis techniques and various different types of special effects, so if the feedback was restricted or filtered in some way to prevent it from happening, then it would no longer be useful to the people who rely on it behaving in a certain way.

The way it works now gives it the most flexibility, allowing everyone to get what they want from it. If you don’t want 100% feedback then don’t set it to 100% feedback. Simple. :)

Yes but you can get some very interesting effects by using ramps unto and away from maximum, or point automation only activating it briefly, which you could not achieve if it was not available so I have to very strongly disagree with you and say learn how to use your tools and figure why you are getting unexpected behaviour before shouting Bug!

For what it’s worth, you can achieve similar self-resonating/feedback/overload situations with some of the other DSP devices as well, including: mpReverb, Chorus, Phaser and Delay. So the Flanger is definitely not alone here.

Hm, you both seem to miss a point here. If I am intending to use it in extreme cases, creating some bad DC and extreme flange, and somehow I shut down output with it’s feedback, how can I undo my error then and regain propper output from a program? If I create something like this, even when closing flanger completely or shutting it down, output of Renoise will not be back. For me, that kind of behavior is erratic. There must be a way to come back from coma that isn’t complete shutdown of a program. Maybe I am wrong, who knows, maybe Renoise will be back after some time, but it seemed not ok to me as a user. But what do I know.
And what about automation? Is there a bug, or I am wrong about that also?

I mentioned alluded to two ways in my post!

  1. Panic Mode. Done by clicking on Stop Button twice.

  2. Move the Feedback Fader down. As the effect is still active it is still self-resonating so move the slider down and the noise will dissipate.

Have you tried double clicking the stop button?

Stop song/pattern playback. Click twice or right-click to activate Panic: stopping all sounds immediately.

@see: http://tutorials.renoise.com/wiki/Transport_Panel

As to this one, which I initially missed as a separate issue, I would guess is down to the Look Ahead functionality of Renoise. Renoise does not store default value at the start of the Song, would be impossible as it is Pattern based, so if you Automate a parameter it will look ahead and the song will start with that parameter at the first value of the automation, no matter how far through the song the automation starts. If you do decide something requires automation it is good practice to then insert an automation point of the start value in your first pattern, so it starts at the correct value at the start of the song.

If it is something else then please elaborate on the issue you are having.

That has solved it, thanks! I haven’t even tried this solution, I thought that simple stop is all that is need to regain control. This was my mistake and I am sorry about that. I felt stupid in one moment, but now I am glad that had learned something new that will help me later.

As for automation, it seems that it doesn’t update itself, something just like you said. If I make automation point in first pattern, it will work for that pattern, but will stop reacting after changing to next one. Please download this song to see and hear a problem. So only solution is to reinit a pattern with value that I need.
And thanks again for clarification about first one. I know I can be pain in the ass, but that’s because I am software tester by profession, so I need to argue all the time with developers :)

Are you talking about automation of Cutoff on Flanger? If not sory am on PC so can’t check. But my guess is your problem is it sounds like the 09xx break is dry in pattern 2. This is due to you having a Point of automation in the last position of Pattern 0 setting Cutoff to maximum, so the effect is pretty much inaudible.