Renoise 2.8.0 Not Detecting Ableton 2.2.8 As Rewire Master

Steps to Reproduce:

  1. Install Ableton 8.2.8 on Mac running OSX 10.4.11 - 32-bit
  2. Install Renoise 2.8.0 on the same Mac (while Ableton is not running) - 32-bit
  3. Close both applications and start Ableton first
  4. Then start Renoise

Expected Restult:
Renoise should detect Ableton as ReWire master upon start up with a dialog box to confirm.

Actual Result:
Renoise starts up without the ReWire detection.
Starting Renoise 2.7.2 detected Ableton Live 8.2.8 as the ReWire master.

I’m using the 30-day trial of Suite 8 (8.2.8, full license for Live 8) Mac 32bit, OS X 10.6.8 and Renoise 2.8.0 (full license)

I followed your steps and it worked fine. Not much help in de-bugging your set-up, I know, but here’s an instance where it is working, FWIW.

Anyone with Osx tiger 10.4.11 can repro it? Is there an application logger that I can attach?

Ableton 8.2.8 I meant

Having the same issue here as well… Everything was okay until upgrading to renoise 2.8 - Now will not detect rewire either way around… (ableton>renoise or renoise>ableton) - Nothing has been changed with ableton - Using Mac OSX Lion.

I did accept the install of the rewire device upon initial startup of 2.8 as well…

Reading the cubase post, Ill try d/ling the 32bit renoise, hopefully thats the issue

32-bit should at least work, if it doesn’t it then sounds like some issue with either Mac or one of the setups but since 2.7.2 works flawlessly it looks like something with the Renoise 2.8 setup somewhere. I only have no real idea where to manipulate in the hope to notice any changes in behavior…

Ok, so when loading the 32bit as rewire slave it ways it can not open the rewire engine and gives an error box… Not working still
the 64bit does prompt for the rewire install - but does absolutely nothing…

Im stuck here, My workflow is dependent on Renoise and rewire… Usually doing my vsti work in ableton, and sample based work in renoise… The 2.7 version worked perfectly. I believe the beta’s did too although I can not be certain.

edit: Well, some progress, I got the 32bit working, need to run it first, accept the rewire install, close out then open ableton, then renoise again…