Renoise 2.8X64 (Linux - Kxstudio) - Crashing On Startup

I started submitting this into the bug forum but part of my installation process might be at fault so I thought I’d post for help before crying bug…

This is a fresh OS install. I wanted a latest and greatest partition right next to my trusty avlinux partition. KXStudio is a bit ahead of the curve with linux audio software (literally the OS is your DAW) so I decided to go down their suggested install path:
install ubuntu studio 11.10 x64, then install the kxstudio repos and metapackages. Did this by the book, no issues as usual.

Along with all the other a/v packages I installed kxstudio-meta-non-free, which includes a renoise 2.7.2 demo.

I downloaded and unpacked the 2.8x64 linux beta, browsed into the resulting folder
Typically the way I would install my reg’d renoise onto these distros that come with the renoise demo is by simply copying my unpacked reg’d binary over the demo binary in /usr/bin/

I did that, tried to run renoise (simple “renoise” in terminal)… renoise starts to launch, i see the splash window with 2.8 beta, and my name in the reg info… then the splash goes away and the terminal is filled with crash-log spew.

ok, so of course I then realize “hey dummy you’re pasting a 2.8 binary over a 2.7 binary”… I run the renoise 2.8 and 2.7 uninstaller for good measure, but then after a reboot (whether necessary or not) and another go at ./ from the unpacked 2.8 beta I get the same results when attempting to launch renoise 2.8 beta.

any clues as to what steps i should go about to rectify so i can run the 2.8 beta on this system?

Does it also crash when you launch Renoise directly from the downloaded folder ->
cd downloaded_rns_reg_something

Please also attach, send us the crash log. It can be found at:

There clearly is something in kx’s non-free-meta package that apparently conflicts w/ the 2.8 beta…
i did an apt-get remove renoise,

Re-downloaded the renoise beta, unpacked and reinstalled … not without running into several permissions issues … sudo ./, installed fine, but the user who installed renoise w/ the sudo command couldn’t launch renoise… could only launch w/ “sudo renoise”. Renoise finally opens but with some bizarre theme.

Wiped the partition, installed ubuntu 11.10 alone, of course as expected renoise 2.8x64 beta installs fine, launches fine… none of the above mess…

I’ve been using kx on top of ubuntu studio 10.04 w/ no issues - renoise 2.8 beta worked fine… but talkfx now recommends going with ubuntu studio 11.10 as a base for kxstudio’s repos. I’ll be giving it another go but just wont install the non-free stuff, which afik installs reaper, piano teq, renoise and each and every renoise tool in the db. I can get all of this manually for now.

tl;dr? issue was clearly caused by kxstudio-meta-non-free packages. renoise 2.8x64 beta installs and runs perfectly on ubuntu studio 11.10 base.

If Renoise is crashing, it’s also somehow Renoises fault. Will give kxstudio a try some when to check…

ok… here are my installation notes to get there from ubuntu studio 11.10:

sudo add-apt-repository ppa:kxstudio-team/kxstudio
sudo apt-get update
sudo apt-get install kxstudio-repos
sudo apt-get update

sudo apt-get dist-upgrade;

sudo apt-get install <each requires a “Y” confirmation>


sudo addgroup whoami audio

as stated, it is the kxstudio-meta-non-free install that installs the renoise demo. this is where things seem to get mucked up. I’ll be going through this again this weekend (wanna get this system set up fresh for rpm2012!) and will report with any findings. . .

If you get to trying this out before I get a chance I’d recommend first going through everything above except the non-free packages.
-reboot, do the kx welcome steps when prompted after log in
-Install renoise 2.8 beta, test it out… it will probably work fine.
-remove/uninstall renoise, then install the non-free packages.
-again try to install the renoise 2.8 beta.

It would be interesting also to see if you experience some of the same issues I had with unpacking the renoise tarball after installing kxstudio stuff using the gui Archive Manager. after experiencing some issues w/ the gui i just used tar in the command line and the files unpacked fine. note my bizarre permission issues with then launching renoise commented on earlier.

so I’ve been in a Direct Data Networks training class all day for our studio’s new 9900, had time and ability to do this in the bg :)

Indeed, if you do not install the non-free meta packages the 2.8x64 renoise beta runs perfectly fine.

edit: I also did not install
kxstudio-meta-conflict (apparently cleans up “unnecessary” packages) nor did i install any of the video/gfx stuff for either kx or ubuntu studio.