Renoise 3.3 uses the wrong full screen on macos

Renoise 3.3 still uses the wrong full screen mode on macos mojave (the last viable macos if you have 32 bit applications that need to keep working), where instead of being a new full screen “virtual destop” like everything else (respecting control+left/right etc), it does something custom, which it shouldn’t be doing.

1 Like

Pix or it didn’t happen :slightly_smiling_face: seriously, let’s see it.

Why? Just fire it up on macos, easy enough to see that its full screen mode is not the standard macos fullscreen mode but some custom “set width and height to screen dimensions and set layer priority to top” resizing, instead of the universal “run in fullscreen mode on a new virtual desktop”.

Not sure why you’d think “having a picture” would be helpful here. The fact that it merely looks full screen is the only thing that doesn’t give away that it’s doing full screen wrong =)

Windows users might not understand what this is about. macos has introduced some weird fullscreen mode of apps, if you expand an app window, macos will expand the window and put it onto a new virtual desktop, even if you did not define any in your system prefs (virtual desktops on macos actually work very nicely, there is no such a good thing for Windows). Personally I don’t like that at all, I would expect that the expanded window goes fullscreen right on the virtual desktop it was before, but I guess that is just a question of habits.

What I actually miss in Renoise fullscreen is the song title display. Often I keep (even multiple) Renoise(s) opened to come back later for audio work. Then I don’t know anymore which version I did exactly load in fullscreen, can’t read the filename. On a sidenote, the idling of Renoise is pretty annoying, since it uses so much cpu. If the window isn’t focused - on a non visible / covered area or virtual desktop - it could save a lot of more resources, e.g. the whole GUI processing could be stopped, which takes a ton of CPU constantly on macos on a 4K resolution or more.

No, i think you misunderstood: I mean it should stop to draw the GUI, if it is not visible. It still can process audio of course. But currently, it also constantly refreshes the GUI, no matter what. That makes no real sense. macos even provides mechanisms to not draw partly covered areas and so on, pretty sure, Windows provides such stuff, too.

Renoise takes a lot of CPU only for the GUI redrawing.

No, if the GUI is not visible, it does not have to be refreshed at all, that’s at least common in modern OSes. Once the user comes back, the GUI of course is refreshed immediately, without noticing that it wasn’t updated in between. And Renoise takes a lot of CPU for the GUI, much more than the most other (GPU accelerated) DAWs. Especially on 4k, which is four times the pixels of fullhd. On macos and 3k, Renoise GUI takes about 35-40% of cpu on a core i7, with an empty song project (I think maximum is 400%). Which is like 10% on Windows tak manager. 10% while idling.

Because I’m on OS X Big Sur 11.2.3 (20D91) and am having no issues with either true “full screen” or a fully-expanded window. In fact, if you hover over the green button (with a mouse), you’re given a choice of entering the true full screen or tiling the screen in its windowed mode to the left or right of the screen.


A picture would be great to see exactly what your issue was. Depending on your version of OS X, these options might not be available. Kinda like if you have a leak in your house and you call a plumber. When the plumber gets there, showing the plumber where the leak is would save time, versus having the plumber inspect the entire home.

Mojave (because tons of folks with very nice, but 32 bit, audio kit will be stuck on Mojave until 32 bit backward compat is somehow put back into macos. Which is unlikely to ever happen =)

There is no “hovering over the green dot”, renoise doesn’t offer one: there are no red/yellow/green dots in full screen mode, and moving the cursor all the way to the top does not do the standard “revealing the macos menu bar + application title bar with red/yellow/green dots”, it instead only shows the macos menu bar. Also, long-pressing on the green dot when not full screen doesn’t actually do what it does for every other app (change the UI from plain view to a window management view), instead it does nothing.

cursor all the way up top:

Having said that: your own screenshot isn’t Renoise but some other application (and sure, all of those work fine for me too, from Ableton/FL Studio to Firefox to VS Code, they all full screen the proper way), so what does full screen Renoise look like for you in Big Sur?

1 Like

@EatMe control-left/right are the universal macos “switch virtual dekstops” keys. Even if an application has their own bindings, macos “wins”, because it should. In the same way that applications don’t get to intercept ctrl-start-left/right in windows (the win10 equivalent for switching virtual desktops).

In fact, with multiple applications in full screen, control-left/right still work as excepted, switching virtual desktops in macos, even when focussed on Renoise, because macos wins. However, because Renoise runs “on the main desktop”, it’s literally covering up any other application that might also be running, it makes the dock inaccessible, etc. etc.

Here’s what I’ve got for full-screen in Big Sur:
Screen Shot 2021-03-19 at 4.40.27 PM

As for the green dot in the upper-left hand corner of the screen, i can’t screen shot the options that pop up when I hover over the green dot (I can’t make my mouse be in two places simultaneously) - I had to find a picture of it on a separate application to make sure you could see what I was talking about, to share.

If I want to exit full-screen, I move my mouse up to the top of the screen , and the Renoise menu drops down, and I go to ‘View’ and select the ‘Full Screen’ option, which disables it. It is odd that the Renoise menu doesn’t show up for you when hovering at the top of the screen with the mouse. Maybe Renoise is being fussy and it wants you to click on the screen somewhere, for some unknown reason. it’s something I would try out of frustration if I were in your shoes.

The key-command I could use to make the full-screen enabled is ‘Option-Enter’ in my version of Renoise, I’m on Renoise 64Bit - V3.3.1 (Built: Jan 11 2021).

Thanks for showing us these pictures, they are VERY helpful in seeing what your issue is. Specifics are FANTASTIC! If none of what anybody is telling you is helping, please notify @taktik - I’m sure he’d be the most helpful in this situation.

That’s… why I posted in the bugs forum? I wasn’t looking for a community discussion, I was filing a bug for the devs to look at, because this is the subforum to do that?

As for not being able to have the mouse in two places: no need, just use cmd-shift-4, and it preserves what you see so you can screenshoot it.

As for “picking view and exiting full screen”: that’s not the macos convention, and you know it. You should get the app’s own bar, with red, yellow, and green dots, so you can click “green” and exit full screen. Macos has conventions, Windows has different conventions, but following the conventions for the OS you compile for is good policy.

Well, I’m done. Good luck!

has this been fixed?

Nope, still the same.

1 Like

awesome. they really don’t care about macOS at all do they.

They do, but update are not so frequently. I think this one was lost simply.