Renoise 3.4.3 | 64bit Raspberry Pi (Bookworm) | Window manager issue


Renoise 3.4.3 on Pi OS 64bit Bookworm (latest release, fully updated at time of writing) doesn’t appear in the native window manager and am unable to move the window containing Renoise around the screen. It is locked to the top bar.

You can full screen, minimise, and you can drag to increase size of the Renoise window, but you can’t unstick the window from the top of the screen and move it around, and Renoise doesn’t appear to be windowed in the native window style (you can see the expected native window style if you look at the Jack window in the screenshots below).

Renoise operates as normal otherwise. Small bit of speculation, the recent release of Pi OS has moved default window manager from X11 to Wayland.

Steps to reproduce look like this:

Launch Renoise
That's it.


Initial window state

Drag corner to resize

Full screen

1 Like

I used raspi-config to change back to X11/openbox, and although I can now move the window, it still doesn’t adopt the correct window style.

Then when I reverted to Wayland and rebooted, the previous behaviour was back but the Renoise window wasn’t stuck to the top of the screen but stuck in the last position I left it in when I closed Renoise under X11 settings.

Some screenshots:

raspi-config version 20231018 (latest at time of posting).

Option for switching off compositor appears to be gone in this version. Have these options now.

Switched back to X11 to test, got the compositor error (directions to switch off are now out of date).

Switch back to Wayland and window cannot be moved again, but is stuck in last known position from previous session under X11.

I’ll give this a test on Pi OS 64bit Bookworm soon too. Could you please in the meanwhile test if the following fixes the issue for you:

While Renoise is closed, open Renoise’s config.xml in a text editor of your choice. The config.xml file can be found at ~/.config/renoise/VERSION/config.xml

There should be a <ForceUsingSystemWindowDecorations>false</ForceUsingSystemWindowDecorations>
change this one to <ForceUsingSystemWindowDecorations>true</ForceUsingSystemWindowDecorations>

When you start Renoise now it should have a decorated border.

Hi Taktik.

Thanks for your response.

I followed your instructions and indeed this returned a window border, and I was able to move the window around the screen. However, in the process, I noticed that some windows open without a border and are therefore unable to be closed.

Preferences, song options, and song comments all open without a border, so I am unable to close them.

But the tool browser does have a window. See screenshot.

I tried testing this with force window decorations set back to false. The Renoise style window borders were back (see screenshot below), but moving these windows around is janky, and includes the window flickering around the screen as I move it, and overall sluggish and glitchy handling.


Thanks for testing. Although it wouldn’t hurt to start explicitly supporting wayland in Renoise, this is quite likely a problem in wayfire. Wayfire is quite new and the Renoise window handling on X11 is proprietary. This is likely to cause troubles.

Preferences, Song Options and Song Comments all open without borders, so I cannot close them.

They are all not resizable. We’re setting the following decoration hints for windows with a system caption bar (decorated windows):



Probably Wayfire skips adding decoration when no MWM_DECOR_BORDER is set?
I’ll test this once I have a test setup on a PI with Raspberry Pi Bookwork installed.

Apropos: If windows are not decorated, Renoise will move and resize them “manually” via “XMoveResizeWindow”.

There is a similar recently closed issues regarding window movement:
See Very poor experience using ardour on latest wayfire 1eb7e4d7 · Issue #1890 · WayfireWM/wayfire · GitHub

It would be great if you could add a new issue for Renoise there as well. I’ll chime in and either fix this in Renoise or help fix the problem in wayfire once I have a test setup on a PI with Raspberry Pi Bookwork installed.


I have raised a new issue. Started to feel slightly out of my depth finding out what version of Wayfire is on this Pi, and using GitHub at all! Haha. But hopefully you’ll be able to chime in on it.

Many thanks for your advice Taktik. I’ve got another Pi that is still on Bullseye and I’m Renoising happily on that one.


There no urgency yet, but I wanted to point out that the next Fedora release is likely to drop X11 support for the commonly used window managers. It’s definitely decided for KDE, Gnome is likely following. Once that is happening in the next 6 months sometimes, it’s quite possible that other distributions will follow. I think there are still problems with Renoise on wayland, especially with drag and drop as far as I can remember.