Renoise Alpha Users With A P4 Supporting Ht

i’ve once reported that since the release of the first renoise 1.5 alpha, i was getting very bad performance (high CPU load) on tunes that in 1.281 didn’t stress my P4 that much.
it didn’t take too long and the culprit was found: HyperThreading.
as soon as i disabled HT, everything normalized again and performance was equally good as it was with 1.281.

during the past few days, taktik and me had some frequent e-mail correspondence concerning this matter and taktik sent me multiple builds with changes, which were meant to fix the HT problems.
however, it wasn’t possible to fix the flaw so far and we meanwhile ask ourselves, if it’s renoise or just my possibly bugged HT P4 causing all the trouble.

so to exclude the possibility, that it’s all just my comp’s fault and not renoise’s, we need your support.

if you’re running WinXP/2K on a Pentium 4 with support for HyperThreading, please do the following:

  1. hit CTRL + SHIFT + ESC (or just open the taskmanager the way you want) and verify that you can see TWO graphs for your two virtual CPUs. if you can’t, then your HT is either disabled via BIOS or does not function properly and testing on your machine won’t be of any use.

  2. download this tune: click
    and unpack it with winrar.

  3. fire up the latest renoise 1.5 alpha build you have (should be the one from aug09) and switch to windowed, non-fullscreen mode.

  4. load and play the tune you downloaded under step 2.
    (if you can’t play it because you instantly get a CPU load of 100% and experience stuttering and cracking, reduce either the number of channels or the output samplerate)

  5. keep playing the tune until the CPU Load display in the upper left corner of renoise has stabilized and does not fluctuate anymore.
    as soon as the value is stable for a while, note it or just remember it.

  6. re-open the taskmanager (the tune should be still playing…) and locate the “Renoise.exe” task in order to perform a right click on it.
    in the context menu, head to the 1st entry from below (it’s called “zugehörigkeit festlegen” over here. it will be named differently depending your OS’s language - probably “set affiliation” for english versions) and disable either CPU 0 or CPU 1 by unchecking one of the two.

  7. focus the renoise window again and see if the CPU meter in the upper left corner has changed. note / remember that value.

  8. come back to this thread and report your findings, naming both values, before and after disabling one virtual CPU for the renoise task.

  9. thank you :)

Ok… Before I’ve said I’ve had no problems with HT and v1.5. Now seeing the results in numbers I can say that’s not really true. Decreasing to 8 channels and switching between CPU0+1, CPU0 and CPU1 and couple of times, I got the following results:

CPU0+1: 58%
CPU0: 41%
CPU1: 45%

One thing is the performance, the other more important task is if you get problems with VST`s when HT is enabled.

  1. Can you reproduce the VST problems that Keith has when enabling HT ?

This is : Drummatic randomly crashes when HT is enabled and Wavestation plugs sound distorted when HT is enabled.

Ehm, but this means that, with HT enabled, the overal performance is below 58% (about 43%). Or do I get something wrong here ?

It would be better to compare the CPU amount that Renoise shows (which is the AUDIO performance only)

CPU0+1 means HT is enabled. CPU0 and CPU1 means HT is disabled. Hence 58% with HT enabled, 43% with HT disabled.

I did.

I will also test with Drumatic more to see if I get HT-specific crashes.

maybe i shouldn’t do that, but i take it as granted, that if the HT performance bug is present, the VSTi bug will also be present.
i never had the situation that only one of the two bugs (perf/stability) was present and the other wasn’t.
it’s not either or, it’s always “and”.

so if johan or anybody else is getting the HT issue on CPU load, then he’ll most probably also get the stability issue, i’d bet my a** on it ;)

but johan, if you could check drumatic for a while to see if it works without hickups for longer than 5-10 minutes playing something continously, it would certainly not hurt.
when you got both CPUs enabled, it should cease to play audio after a short time.

CPU 0 + CPU 1 = HT enabled, both virtual CPUs are operating
CPU 0 = HT disabled, only one virtual CPU is operating
CPU 1 = HT disabled, only one virtual CPU is operating

what i don’t undestand is, why johan is getting different performance from single CPU 0 comparing to single CPU 1.
i don’t experience that, but sometimes it really takes a while until Renoise’s CPU load display stabilizes.

22050 - HT 50%, CPU0 48%, CPU1 47%
44100 - HT cannot really play, stutters some, 97%, CPU0 95%, plays nice after CPU load has risen to max.
44800 - HT no workin’, CPU0,1 no workin’n’, stutters

no channel reduction, 2.4c HT 800mhz, ASO latence 512 samples

You see, no dramarical changes. Note that in 1.281 I cannot play the song 44.1khz in any case. CPU load is always 100% or 99.x%. 22050 gets same results in both versions. The only difference is that 1.5 stopped responding couple of times while 1.281 did not…

Hope this helps.

I’m such a helpful-Joe and do-gooder that I tried the drumatic2.2 too even thoug I wasn’t asked to. Here’s what I experienced.

->desktop wallpaper

Also one time it just stopped playing audio and when I tried to load another VST in it’s place the Renoise freezed with CPU load in 100%. Log was filled with same text over and over.

Wanna logs? Shout!

note edited some error message typos

Ok, sorry. I thought 0+1 means HT disabled.

this is exactly what i experience when enabling HT in Renoise 1.5a.
I sporadically got the same Crash with the same error message popping up in a dialog box when using drumatic2.2.
what i always got, was the loss of audio from drumatic after a couple of moments.
thanks for confirming this, too!

I can’t say much about HT as I’m on an Athlon 64 atm, but as far as the Drumatic problems go, have you tried to contact E-Phonic about it?

in 1.281 it worked okay, also with HT - so it should be a host issue i guess.


Just tested the file on my system (p4 2400 HT) using rns1.5 alpha3

At 44khz 16 channels
0+1 cpu = 74%
0 cpu = 71%
1 cpu = 70%

At 22khz all (30) channels
0+1 cpu = 59%
0 cpu = 56%
1 cpu = 54%

Concerning the Drumatic2.2 vst (my fav drum synth!).
I never had any spikes or crashes with this plugin in previous rns versions.

However, I just tested it in rns1.5 alpha3, and when entering notes I managed to trigger the 100% spike.
Next, quitting renoise had to be done using the task manager, since it stopped responding after I tried to close it normally.


same symptoms, but just opposite way around. I am most likely to get the error message and Renoise kill.

Yes, I noticed that whatever I do after reaching the 100% CPU strain, which cannot be cured even with panic button, my HD goes mad from writing the log, Renoise freezes and must be terminated with the way described.

But how come my Renoise eats less CPU than Rhodes’ one? :) Ok, offtopic…

Got this crash and the sound disappeared too. However I haven’t tried it enough with HT disabled yet. Will do asap.