Renoise as ReWire client to a REAPER host

Not a total noob, but struggling here, and feeling there’s something obvious I’m missing.
Setup = Windows 10 machine with Renoise64Bit V3.4.2 and REAPER64Bit v6.60

REAPER is currently the evaluation edition, Renoise is a purchased edition.

What i want to do is “simply” record the output of a track or tracks, from Renoise into a track or tracks in REAPER.
I have managed to get REAPER to act as the client (or slave) to the Renoise host (or master), but can not get it to work the other way round.

Process goes like this: start REAPER first, create new track, click on FX, attempt to add “ReWire: Renoise”
but am unable to, as the only entry in the ReWire section is ReWire: REAPER which would be creating another REAPER running as a client, not what i want - but could be interesting to experiment with.

So to recap, I want to run Renoise as a REAPER client but can not find the ReWire: Renoise “plugin”.

Is this a just REAPER issue ? or am i missing something that needs to be installed…?

Would appreciate some help.

Cheers

PukekoNZ

Anything here help?

Hi there thanx for the reply, I have seen the link above, gave it a go but no luck, (and its old 2011?)
Apparently PropellerHeads have made ReWire obsolete… wondering if I should roll back both my versions of REAPER and Renoise untill I can get it working.

What a hassle to achieve something apparently so straight forward ( routing audio from Renoise into a “simple” DAW ). I am however a GNU/Linux user from way back, which is where I got my first taste for Trackers - used to be an excellant one called “SoundTracker”, which with the right sound card; would actually resample itself !! Total gleefull insanity.

I just figured that being newish to REAPER, the better option would be to use MS Windows as it apparently has more available VSTi VSTs etc

What’s available that can route audio from Renoise into REAPER these days as ReWire doesn’t seem to be an option, ( on Windows btw ) ?

Cheers

PukekoNZ

Don’t despair. I’ve done this in the past on Windows. I’ve even creates some simple Reaper projects I can refer to so I can recall what I did.

Thing is, I was trying one out, and while I get the link between Reaper and Renoise, and can get the output of Renoise master going to Reaper, when I arm anything and record it records nothing,

Now I need to go look for any notes I may have made to see what’s going on.

Have you tried it like this:

  1. Start Reaper
  2. Start Renoise (asks if you want Renoise to be slave, answer yes)
    FROM REAPER:
  3. Insert Rewire:Renoise plugin in Reaper
  4. Add 64 tracks (if you want all 32 stereo rewire channels) for that same Reaper track that has the Rewire plugin
  5. Configure channels from Rewire plugin
  6. Send Rewire channels to individual tracks
    FROM RENOISE:
  7. Send tracks to Rewire

I just managed to do this today and even my Faderport and Launchpad works in Renoise even though it’s in slave mode.

Freezing Renoise tracks from Reaper worked when I added dummy midi item. It’s a bit akward but way better than with Renoise tool’s “can only freeze one track at a time” style.

Hiya thankx for the your reply - sorry for the late response.

Your suggestion does not work for me unfortunately, as it fails at number 2 and then 3.
Reaper is running , then I start Renoise (which doesnt ask me if I want it to be a Slave at all).
And then the ReWire:Renoise plugin does not appear to exist at all in Reaper (the only thing i can see is ReWire:Reaper plugin).

The only “success” i have had is starting Renoise first, then adding a ReWire input to a new send track, selecting Reaper as the option which then gives me an input signal (as there is existing audio in Reaper) and then using the “Render to Sample” function to grab the audio comming in from Reaper.
A minor triumph - and useful, but not what i really want…

Any ideas crew ?

Cheers

PukekoNZ

1 Like

Hey there, how did you go ? - any luck ?

Cheers !!

PukekoNZ

I am at work so I can’t test anything, but it make sure you have the rewire dll in your vst folder. If you don’t maybe thats why the renoise one isn’t showing up. Also I would try not opening renoise at all. Open reaper, then if load renoise rewire vst in reaper and that will open renoise for you in slave mode. Rewire dll can be found here: rewire.dll free download | DLL‑files.com

This doesn’t happen for me (though it has in the past). I open Renoise after starting Reaper but I get no prompt about being a slave.

Nope no luck.
Put the Rewire dll into usual appropriate folders - but still no Rewire:Renoise available that I can determine.
Didn’t make any difference.
I am using “latest” Reaper v6.62 evaluation edition, and a legit Renoise v3.4.2

Did find this in the Renoise forum though, MIDI only i think - and Bitwig not Reaper:

GAME CHANGER Connecting Renoise & Bitwig Studio with Blue Cat Connector

Could be worth experimenting with…

Cheers

PukekoNZ