Renoise Does Not Show Up On Windows Sound Mixer

Just as the title suggests, Renoise doesn’t show up in the Windows Sound Mixer.

It also doesn’t show up in EarTrumpet.

Given how loud Renoise can be compared to other apps, this would be a great feature to have working. It’s just plain weird. Something to do with ASIO perhaps?


Edit: I running 64-bit on Win 11

Yeah, same on Win 10 Pro.

DirectSound shows up and works. ASIO, nope. It’s there if I change to ASIO after I open Renoise but it does nothing. If I then close and reopen Renoise then it’s not there. But it appears again when I go back to DirectSound.

ASIO drivers have their own control panel and don’t show in the Windows sound mixer. But the ASIO control panel also doesn’t have volume controls. You just can configure buffers, samplerate and virtual audio in-/outputs. If you wanna have Renoise also in the Win sound mixer, you have to use DirectSound or WASAPI.

The whole point of ASIO is that it bypasses the Windows audio stack entirely and instead communicates with the audio hardware directly (for efficiency and latency reasons), so it makes sense that Windows isn’t at all aware of applications using ASIO for input and output.

If you want see it in the mixer, use a Windows API like DirectSound. (I think WASAPI probably should work too, but doesn’t seem to. Any comments on that from people who who the inner workings of the Windows audio stack better?)

WASAPI should work without issues. Here on my Win11 system it works like a charm with Renoise. With WASAPI Renoise should appear now in the Win Mixer. WASAPI also should have less latencies than the standard Windows APIs like MME, DirectSound and WDM.

WASAPI may cause some issues if you’re trying to add a In device for the audio inputs of your audio interface because it normally isn’t concipated for music production and recording purposes. It’s also just a standard Windows API (Windows Audio Session API) and is originally concipated for audio playback only.

If you get an error message, when you try to set the Renoise Audio driver to WASAPI, try to set the “In device” in the Renoise audio preferences to none and re-initialize the drivers. This may solve it, but then you can’t record audio via the audio ins of your interface.

Indeed now it shows up in the mixer when using WASAPI, for some reason wasn’t working yesterday when I tried.

DirectSound for some reason is more stable than WASAPI for me though. WASAPI doesn’t wanna go below 384 samples @ 44.1kHz (which Renoise reports as 10ms, but that number is obviously not correct), and it’s already kind of unstable there, and oddly enough completely broken at 512 sample buffers; only 1024 sample buffers and above are fully stable (at ~23ms). This is when the “exclusive mode” is turned off, as things get even worse with it turned on.

DirectSound on the other hand is completely stable at 10ms and still ok at 5ms.