Renoise Gui Slows Down When Recording Lots Of Input Data, Notes

@gentleclockdivider: Did you test with 2.6?

yep , just did on my friends comp .dual core laptop , 2 gig ram …lagging after a few patterns
Conner , you also have the problem , what are your specs ?
I know my lapop is not up to date , but try to see it from my point of view , I get all my sounds from my nord modular and reaktor , sometimes sequenced and or resampled and a microphone , so I have acces to a plethora of sounds and don’t need the latest high spec .laptop to run every vst imaginable , I am a more is less dude ( and don’t have a lot of money at the moment …I like travelling )
So my computer is capable enough of running renoise , But now since the added feature ( which I personally don’t care about ) makes renoise useless to me , just because of this I can’t record live anymore , if the new feature would be something like a cpu intensive additive engine , then I would upgrade my computer to run renoise 2.7 , but it’s not , it’s just an under the hood one step undo feature , that takes up precious cpu juice ( on a older laptop ) .

I will now

Sorry, I’m having a hard time understanding you. In your next post can you be more clear and leave out the personal stuff?

This is what I understand.

  • You tested 2.7 an 2.6, BOTH have the SAME problem?

If the above is true then:

If 2.6 and 2.7 behave EXACTLY THE SAME then the new feature is NOT the problem.

Ahhh, ok. I simply misunderstood. Looking forward to the report!

ok just tested it with renoise 2.6 , recording from computer keyboard , no quantize , note delay on
Absolutelly flawless registration of recorded notes , no lagging , no slowing down gui …

No they don’t behave the same way , just tested renoise 2.6 , absolutely no Lagging
Renoise 2.7 , lags …the lagging happens on my computer ( old single core ) and also on my friends computer ( dual core )
What spec’s do you have , since you mentioned that you have the problem too

They are in my signature.

Although this doesn’t affect my note input workflow as I’m not a keyboard virtuoso and do everything manually, step by step, i.o.w not live, this is definitely a problem if you want to key in your notes for more than a few patterns.

I know a Jazz keyboard player that is still learning Renoise 2,6 and he would have a problem with upgrading to 2,7.

+1 for fix.

To me, it’s hugely useful to be able to undo multiple note recordings in one step, so I am very happy about the change (not having to press CTRL+Z a million times to undo something that was entered using keyrepeat, for instance) . On the other hand, I can easily picture some keyboard maestro getting into trouble because of this, like Jonas points out.

Perhaps a solution would be if the merging of undo steps could simply wait until playback was stopped? So, while playing the undo is only working on single notes, but when stopped (and nothing has been undone), the merging takes place and the whole thing can be undone.

I’m guessing that the merging takes place when notes are entered at a certain speed, so it’s obviously more complex than that, but that’s my 2 cents…

ive never ever used undo in the pattern or song editor.
is there an option to disable the whole undo table?

Let’s roughly split the undo takes for each new pattern. That should should solve the GUI performance drop while being helpful in general to undo takes.

u r oldschool, man

great that your coming up with a solution , but can’t we just make it an option instead of your proposal of undo per pattern ?
The problem occurs here on a dual core @ 2.6 ghz after 4 patterns of 64 lines long , that 's 256 lines ,
Or in a 512 line pattern , llagging begins at 300 .

What if a pattern is 512 lines long ,and a slow song tempo , people with older computers ( like me ) will still encounter the problem .
PLease make this undo feature optioanl in the preferences .

ctrl tab …set focus to pattern matrix
Select blocks …press delete

just wondering , do we have to wait for another release for this fix ?

There’s a few things in the Pending section marked as Fixed and not yet released so I strongly suspect we will see a 2.7.1 before too long ;)

A 2.7.1 is on the way. But we can’t do more in 2.7.1 than splitting takes per pattern. An option to disable this completely, would not be enabled by default, thus this option would only solve your problem (and those who have followed this thread). So we need to find something which does the job without an option you have to turn on first.

So let’s please go for the “splitting takes per pattern” now, maybe roll this up again in upcoming bigger releases - add more option to control this bahavior there.
On the other hand its “only” a GUI slowdown, and this only happens when constantly bombing Renoise like hell for a very very loing time with events. This will not slow down MIDI input and will also not slow down the Audio engine.

Per pattern means that after four patterns, as much was registered as it was for the previous pattern instead of everything from the start.

Because the note-cut recording is severly lacking, 512 lines in slow mode is pretty useless, but when you are recording a slow song, i doubt Renoise should have troubles with keeping up the “pace”.

updated my post about the last take undo issue i have. maybe somebody will read it this time.

problem is still present in renoise 2.7.1
Especially noticeable when using a longer pattern ( more then 128 lines ) , after 128 lines renoise is still unable to register my recordings accurately , lagging like hell …even at a modest tempo of 120 bpm , lpb 8 , recording a bassline at moderate speed is a NO GO
The fix for 2.7.1 is not really a fix , as it only works for short patterns , what bugging me the most is that the taskmanager cpu is still showing a lot of cpu activity after recording some notes ( just 1 active track with no vst’s , just a sample based instrument )
Some posts above taktik says that it’s only a gui problema , it is not .
I really hope a defenitive fix is in the pipeline and not for a major upgrade , one of the most important features of a recording program is not working properly , the ability to record your playings live with a human feel , I remember when renoise 2.0 was released and the note delay function was introduced , renoise is now able to record exactly what you played ,
We need a defenitive fix for this , not some workaround , I suggest making the 'one step undo ’ feature user definable in the options menu …and that it puts no strain on the cpu
Really …I am so frustrated about this …

Didn’t this eventually got fixed with an option to regulate the undo behavior somewhere in the config file in the preferences folder? Can’t find anything real quick.

Certain pre-2.7.2 songs seem to be running with significantly higher cpu here and I’d like to cancel out possible issues.

See [Solved 2.7.2] Renoise 2.7.1 Still Unable To Handle A Lot Of Input Not please