Renoise + Microtonic Drag N Drop Midi

Drag n drop midi it dosn’t work

2640 bug.jpg

renoise 64 osx 10.6.8

Did that ever worked? Even if it would work, it would erase your complete song and try to load a MID file. But i see you use a “Bridged” plugin and this comes with a lot of limitations because bridged plugins run in a sandbox.

Can you please be more specific than “doesn’t work”? What happens exactly?

We have actually never fully supported this particular behaviour where it’s possible to drag MIDI clips out of Microtonic and into Renoise. In the Windows version, dragging the MIDI into Renoise will actually result in your Renoise song being cleared/unloaded, and then a new song is created with the MIDI data. This is the only form of MIDI import we support in general at the moment, so this is really the best you could expect for now.

It that the same sandbox as in Preferences->Plug/Misc->Run all plugins in sandboxes? In any case could you explain a bit about what exactly that option does (I did read “-> separate process”), and what the pros/cons would be of that?

Well, one thing is mandatory:a 32-bit dynamic shell to execute a 32-bit application in. You can’t load 32-bit dll’s in 64-bit compiled executables.
That’s why you have two plugin executables in the renoise folder:AudioPluginServer32.exe and AudioPluginServer64.exe
They probably perform internal routing of audio and parameters between Renoise and the plugins.
If you run the 32-bit version of Renoise, audioPluginServer64.exe is used to bridge the 64-bit plugins and vice versa.
But i think that using a server actually gives one more opportunities regarding keyboard behavior. I think this one can be restored if the server would broadcast GUI specific keyhandler captures directly to Renoise.
There would be some latency, but is still better than nothing.

For the drag and drop problems, i don’t think there is a solution. I tried Addictive drums which has a similar Midi snippet drag function but Renoise even hangs in this case. One would need to drop the mid-file onto the plugin’s own window and this should then be forwarded to Renoise.

This already didn’t work in 2.7.2 32bit on 32bit. So it’s not a new 2.8 bug if you ask me. Microtonic is great but the midi export is not usable in renoise (never was). In cubase or something else it’ll throw the midi data in a new track or something, renoise will see the dropped object as a .mid song.

i think this litle trouble very annoying. too bad =( i dont understand why dont work this very easy export midi file without start new project.


maybe its possible to do it with scripts?

Yes, this was the case with 2.7.2 and lower.
I thought you were discussing the current problem where Renoise 2.8 is completely ignoring the exported file (and responded with that case in mind)

Nopes not yet, unless the Lua functions getting first control on the file import before Renoise decides what to do with it. (Renoise wants to wipe the song regardless whether a Lua script hook is in place or not so the script is not allowed to process earlier than the current song has been cleared)

In that case never mind me. I don’t use it anymore…