Renoise midi sync problems

Hi, I’ve been trying to sync renoise to electribe esx, renoise being in master mode. I’m working on windows 7, i have m-audio fast track pro interface, and it’s not running on any usb-hub or anything. Connection is as follows [Audio interface–>Midi splitter–>electribe]. Midi splitter doesn’t introduce any latencies i’ve checked it in different connections and other software.

Now, renoise is master clock, i press play in renoise and both renoise and electribe start, and when i monitor just the esx’s metronome via Line-in device while listening to renoise’s metronome, they are out of sync. In midi prefferences there is a compensation slider for master mode, and when i move it leftmost, minimum value that may be selected is -14ms, still they are out of sync.

When i increase or decrease buffer size in audio inteface’s settings, minimum value of compensation slider varies(f.example: -14ms for 512 buffer size or around -44ms for 1024) , but still when it is leftmost i do have exactly the same delay between metronomes which is about 6ms(i guess). Of course they are out of sync on any other settings of a compensation slider, altough they are more out of synch when the slider goes right.

Guys, please help me i honestly think i did everything to make it right but it seems that renoise just won’t cooperate.

Edit: i play everything in ASIO drivers

You can also toy with the track latency of the track where your line-in-device is at, however i suspect it will only compensate input of the notes to the device than compensating the audio of the line-in.

Exactly. When i want to compensate midi/audio delays that come from my external synths that are sequenced by renoise, i just dial in some negative delay in the mixer view until they are synced, but it doesn’t work at all in negative values when sending the midi clock data apparently. So, anything else i can do?

Maybe I’m playing captain obvious here, but are the instrument MIDI settings set to Ext. MIDI?
This would affect the overall latency applied to the outgoing notes.

This is a common problem for me! But there is a solution…Vv mentioned it. If you can`t delay the MIDI clock, delay the audio input of the ESX coming into Renoise. If the signal is going into a desk alongside renoise…well…then you might need to compensate the renoise audio channels.

Either way you can sort it. I know cos I have ONE midi output daisy-chained though about 20 devices!!

Thanks guys for helping. So that means i have to delay every track except the input track? I’ll have to make a template for it then…

Although I also don’t know about the solution for the midi timing, if you have to make such a template, Renoise has PDC test delay device internally.
(copy & paste this code on the TrackDSPs window. Then turn “Report” button off on the device.)

<?xml version="1.0" encoding="UTF-8"?> true

Maybe it may help a bit, though it’s a quite odd workaround… :rolleyes:

:excl: P.S.
As danoise mentioned above, check again these;

Thanks everybody! The solution i found most useful is combining all tracks except the input track into one group, and than apply the delay you mentioned, or if somebody prefers to set the delay in samples, one may use this, a free vst plugin: http://www.voxengo.com/product/sounddelay/. Thanks!