Renoise not playing on Bluetooth speakers on Ubuntu Studio

Hi everyone :smile:

I am new here, new to Ubuntu (Studio), and new to Renoise - and I have a question I hope you guys can help me with.

I can play Spotify and YouTube on my Bluetooth connected speakers, both via ALSA and Jack. But for some reason I cannot get Renoise to play on my Bluetooth speakers, via ALSA nor Jack.

You help would be much appreciated. Thanks!

  • cigoL

Two days and not a single response. Did I write this question in the wrong place on the forum? If so, I apologize. New to the forum as well. Hope someone can help me out.

What are your settings in the audio preferences in Renoise? Do you see Renoise in Jack? Do other DAWs work? Can’t believe it’s related to Renoise as long the audio is routed to Jack or Alsa.

Thank you so much for writing. :smile: I am not using Jack on my computer, since it seems to not work well with any software, including Spotify, YouTube and ReNoise.
It is set to hw:1,0 (), which plays the sound in my plugged in headphones. I also have hw:1,1 () and hw:1,2 (), as well as hw:3,0 (USB Audio), which plays through my Jabra headphones. I don’t see anything that is the Bluetooth speakers.

Just tried to open Ardour5. This program I cannot even open. It says: “Failed to open audio device”.

Where are your BT Headphones connected to? Is there a BT dongle connected to your computer and does BT work in general?

I’m not familiar with BT headphones as I’m not using them.

It is Bluetooth speakers. No dongle. They work perfectly with YouTube and Spotify.

I guess you are using pulse audio with your browser or alsa. Did you set the renoise setting to alsa and close your browser. Could be that renoise can’t connect as with alsa you can only use one source at once.

I just noticed something else that might be relevant, since it seems to indicate an issue with the audio. I can play Spotify and YouTube via the Bluetooth speakers, but not via the same speakers when they are plugged into the computer with a mini jack.

Also, I cannot adjust the overall volume with the volume wheel on my keyboard for the Bluetooth speakers, but the volume wheel does not change the volume of the plugged in headphones. Weird. Maybe I should just switch back to Windows or OS X. I have not used Ubuntu for more than ten years, and I was hoping sound was better now than back then. It doesn’t seem to be the case. :confused:

I don’t know if I am using pulse audio. But I can hear YouTube (from the browser) and Spotify (app) at the same time on the Bluetooth speakers.

I read that it is better to use Jack for serious audio work. However, Jack does not work on my newly installed Ubuntu Studio.

Come over to https://linuxmusicians.com/
There you get help for sure.

Thank. I will. Is this forum for ReNoise specific questions?

No, but your problem is not renoise related. Please also describe your setup in more detail.

@cigoL it depends a bit on your needs.

If you would like to use Renoise exclusively (no other software, hardware or midi controller to connect) for fun, you can use Pulse Audio. Not the best performance but ok and also no hassle.

If you have a midi controller, i would suggest pure Alsa (this will mean that you can have only one application use audio at a time) and audio realtime priority settings for the kernel. You don’t need Jack for realtime audio priority. Great performance and very stable, setup once and be good, not very flexible.

You will definitely need Jack if you want to connect a lot of audio stuff (software/hardware/midi) with each other or if you would like to use a application that has Jack as a dependency.

If you seriously want to setup a dedicated audio production box to use in a studio with a lot of other stuff, than use Jack, audio realtime kernel priority, a lightweight desktop (or only a window manager), ethernet (no wifi/wlan) and disable all services that are not needed to get the max for audio. The system should also have a good dedicated graphics card (a good, not a high end gaming sli double) to render the UI, so the CPU doesn’t need to do that.

BTT: I guess you need to connect the Bluetooth speakers in Jack, Spotify and Youtube use Pulse Audio by default if not configured otherwise. If Spotify and Youtube can play back at the same time, you definitely use Pulse Audio. Audio production over Bluethooth is really a bad idea, too much latency and overall interruptions.

Thanks guys!

Since I initially asked I have discovered something. When I play a video on YouTube or a song on Spotify, the name YouTube or Spotify shows up on the Playback page of the Audio Mixer (Volume Control). Both of these work great with the Bluetooth speakers or my plugged-in headphones. Today, I got the VCV Rack and after changing to ALSA default, and NOT ALSA hw:broadwell… (in the VCV Rack app) the VCV Rack also showed up on the Playback page of the Audio Mixer (Volume Control) and I could hear the sound over the Bluetooth speakers if I wanted. I also got Bitwig and with Bitwig set to use Pulse Audio, it also shows up on the same Playback page and works great. I can hear YouTube, Spotify, Bitwig and the VCV Rack at the same time.

The problem seems to be that I cannot set ReNoise, nor Ardour5, to ALSA default or Pulse Audio. Is there a way to do so in ReNoise? It is not important for me to be able to make Ardour5 work. I only mentioned this to point out that ReNoise is not the only software that will not play on the Bluetooth speakers. But since YouTube (in FireFox, by the way), Spotify, Bigwig and VCV Rack works wonderfully, it IS an issue with Renoise (and Ardour5).

I am hoping someone smarter than I can suggest a solution. Thanks!

Renoise and Ardour are not supporting Pulseaudio, which is the reason why you don´t hear sound. You have to stop pulseaudio, cause it blocks the soundcard. Not sure about that, but you can keep your Browsers and Spotify closed and kill the pulseaudio process with

killall -9 pulseaudio

Then open Renoise and choose ALSA in the audio preferences. If you type alsamixer in a terminal you can also choose your soundcard in the menu that opens there (with F6).

Best is to use Jack with a pulseaudio bridge, so the sound from Browser and Spotify are routed to Jack. I suggest you enable the KXStudio repositories and use Cadence. It´s all preconfigured and should work out of the box.

https://kx.studio/

I think bluetooth audio in linux will need a special alsa backend to be available in renoise alsa or for jack. Pulseaudio can use bluetooth, but it does via bluez and not via alsa I think… I believe there are special modules to make it accessible via alsa (and by that for renoise or jack…), you might have more luck asking in an ubuntu/linux forum…

Ok, I don´t know how it works with bluetooth. :cold_face:

Hm. The ReNoise developers ought to make it works out of the box as like BitWig, VCV Rack, Spotify and so on. Such issues does not exactly entice new users to stay with the app, when other alternatives (DAWs) just work flawlessly with no issues.