Renoise Plugin keys interfere with Renoise interface

So, whenever I try to type in a number in a VST plugin and press the keyboard keys, the keys register both in renoise and in the vst. So let’s say I want to change a value for a VST reverb, if the VST instrument is selected as well, even though I am operating in the Reverb window, renoise will register that key and trigger keys/notes associated as shortcuts on the keyboard. Any idea why this is happening? On my previous install of Renoise this wasn’t an issue, I could type whatever in the external VST and it wouldn’t interfere. Now whenever I try to change values and type with the keys, I get random sounds popping as well the track stopping because I press enter. Don’t know if I managed to explain this correctly, all I know is that it is driving me insane and I can’t seem to find any resources about this issue.

Thanks…

Have you tried to check “enable keyboard” at the bottom left of the vst gui ?

Does this happen on Windows, OSX or Linux? Does this happen with all plugins or only a specific one?

WIndows 10 Pro 64 bit. Same install as on my laptop. This is a new built PC so no idea what’s happening, it just defaulted to this state.

I believe I tried, is this a general option or available on each specific plugin? Not near the troublesome PC right now but I’ll have a closer investigation on this although I doubt this to be it as I did have a thorough scan through all these options both on the Renoise interface and VST plugin interfaces. I would clarify that this happens on all my VST instruments/effects from different vendors (everything from Kontakt to Valhalla DSP)

The checkbox is in the bottom left corner of each plugin GUI, I have no idea if this setting is global or local for individual plugins, but checking it should prevent key events to get to main Renoise GUI.

Yeah, that’s not it as some plugin’s don’t even have the checkbox and I remember trying that with one VST plugin with no change as to how the hotkeys interfered. Don’t know why but I suspect windows to be the culprit.

1 Like

Ok, Sad… I don’t have this issue on my side and I thought that this checkbox is worn by renoise window… So I think I have nothing to help you :frowning:

1 Like

Now dear.

I know what the problem is.

You should disable Record mode. Keyboard shortcut is [ESC].

If you have it left on, then your keystrokes will go to the pattern.

I am looking for excuses why you are not disabling the record mode by learning to work with Renoise.

I will report back when I can honestly report that I have been making the same mistake 10 years ago.

Same issue, win 10 laptop.
no record mode
example: reaXcomp vst
type in parameter value for for example threshold.
result:
renoise gui reacts to input as if there was no vst window, this activate shortcuts by changing views, parameters etc.

Edit: got it, this is solved by clicking the “enable keyboard” button