Renoise Problem On Ubuntu

I bought myself a Toshiba satellite A200-238 notebook and installed the latest Ubuntu.

Renoise installs fine, but playing back even the simplest demo-song, results in hick-ups that make it unusable…

i’m pretty sure the problem can be attributed to the (shitty) inboard audiocard and this ALSA driver business.

usually i find my way around by just googling, but this time it doesn’t seem to be that simple.

i think my card uses the Realtek ALC268 Codec (if i remember correctly) but that’s about all the info i have


as i’m new to notebooks and linux for that matter, i hope i don’t need to buy an external audiocard just to get my fingers rolling out some beats?

try installing the realtime kernel:

sudo apt-get install linux-rt

at next startup, you should be able to run using the linux-2.somenumbers-rt.

let us know if it gets better

ah, thx will try this. i read somewhere tis was already standard supported in Ubuntu 8…
also running renoise as root, i was able to have this realtime thread running, but it didn’t change anything noticeable…

even more, by messing around too much i just completely destroyed this ‘alsa’ business… so i’m thinking of just doing a reinstall of ubuntu… and then doing what you just suggested…

for all i know, this is all i can get with this ALC268 soundcard… :(

I’m not a good adviser for Ubuntu because I’m very newbie about Linux. :unsure:
But I installed Ubuntu Studio 8.04 and Realtek ACL 268 is same as mine.

Strangely, when I choose ALSA in Renoise, it is not good performance too.
But when I choose Jack (setting by QjackCtl), it improves well. Though I cannot understand why it is…
So maybe it is worth trying Jack control.

Satobox is right: using JACK as a sound server may help. I have ran Renoise under Ubuntu for the first time on my new laptop today and have experienced the same problems you have.

to check out what card you have, run the following command from a terminal:

cat /proc/asound/cards

if your card is shown as HDA-Intel, this is not good news, because Linux has not good drivers for this kind of chipset.

Anyway, you can still achieve good results by setting JACK to run with 3 periods instead of the default value of 2.

It’s very simple to achieve this using JACK Control, which you can install with the following command:
sudo apt-get install qjackctl

open it and go to the setup screen. choose a buffer of at least 1024 and 3 periods. it should run fine now

another thing which will improve performance is chhosing to use realtime threads from
Edit => Preferences => Audio
panel in Renoise, but this requires Renoise to be ran with root privileges.

you can either do this by opening from a terminal with
sudo renoise
which is of course not comfortable, or by following the guide linked here (look for the section named “How can I enable ALSA realtime priority in Renoise?”)

i have not upgraded to ubuntu 8 yet so specifics are not my forte but here is a general idea of something that could help:

you can run lsmod to see what modules (drivers) are loaded.
you will be able to see if alsa is using that hda-intel module.
also, have you ran the upgrades?
sudo apt-get upgrade
could possibly be an upgrade for alsa.

ok, thanks guys!

indeed i have the HDA-intel thing running here.

most of the suggestions i already tried… but not the Jack part and the installation of the real-time kernel.

as i have re-installed ubuntu yesterday it will take me a bit of time to get going again…

but i will update my progress in getting Renoise to work once i get to it.

maybe it would be a good idea to have a cenral place that focusses on Renoise within Linux and its known problems and solutions?

having possibly similar problem with renoise on linux. i use dual-core amd64 machine with last ubuntu studio (which is rt by default) and m-audio delta1010lt card. after some hassle with 32bit libraries i successfully installed renoise and made the “use realtime priority” option possible following the instructions from this forum. so far ok. but when i play a module, i hear constant crackles and distortions. this sorta improves when make the buffer larger, but hey! 4096, latency almost 150ms, and still time to time crackles and cpu usage 20/% with one single channel on! there must be something wrong, on my old iBook with fraction f cpu power and memory i can do 5ms…
with amd64 i cannot use jack, so i have no idea if this would be the solution (being relatively new to linux i did not dare to install 32bit jack)

any help pls?

If you want to use Jack with Renoise, you will need the 32-bit edition of Jack (and the libraries that it depends on).

I doubt you would mess up your system big-time, the only extra careful thing to look after is to take care the front-end (sym)links are being updated and renamed so that you can pick either the 64-bit edition or the 32-bit edition of JackD and JackQTL.

Though don’t expect that you can connect 32-bit and 64-bit jack connections together.

as alien-it said, and as i said in your other thread, setting periods/buffer in jack to 3, while using jackd instead of alsa should likely solve your problem.

also i agree that a dedicated place for linux should be great, since linux is generally a PITA ( :D) and other people may not want to see their forums polluted by linux troubleshooting topics.

ah crap, this is funny, in my case the device type to Jack thing runs even worse then ALSA :blink:

i set the periods/buffers to 3 (even 4)

installed rt-kernel too

no luck <_<

power management in the bios?

if changing periods to 3 does not improve things, then there is no wonder that running under JACK is even slower: JACK is basically a server which calls ALSA, so it is a bit slower than calling ALSA directly: the problem is that in Renoise you cannot (yet) set periods directly in ALSA, so you have to use JACK to do this indirectly.

if it’s a buffer problem, try increasing the sample numbers in jack to the maximum (2048 or 4096 i don’t remember) and see if it improves anything.

Try disabling realtime in jack also.

:( naah, nothing works.

the only thing that does work is running it in vista.

also the visual feedback in vista is much and much more smooth… prolly also better drivers for the graphics card it seems?

When I had choppy audio combined with choppy/slow framerates, it was while running with ALSA enabled, which running with Jack remedied.

This is also kind of interesting, because every now and then Jack dies, and it falls back to ALSA, the only real signifier being the slow framerate.

ctrl+i reinitialise soundcard (sound service) :D

I’m also having slow and choppy frame rates with ALSA, while Jack is ok.

Diptera: are you using a notebook? is your soundcard seen by the system as HDAIntel? WHich version of Renoise are you using?

Since renoise 2.0, you can change the number of ALSA periods in the configurations. See if setting it to 3 improves things

Nope, I’ve got 3-year old Asus motherboard (A8N-VM CSM), AMD Athlon64 X2 CPU (dual core), 2GB RAM, etc.

I’ve disabled onboard audio via the BIOS. I’m using a cheap PCI audio card, which sadly works better on Linux than my somewhat expensive USB 2.0 audio interface.

2.0 b5

Thanks for the idea… but after trying 3, 4, 5, 6, there was still no effect. Disabling PDC and real time priority also had no effect on the graph refresh.