Renoise -> Reaper Rewire Synchronisation Problems

OK, just installed Reaper to use it as a final mixdown tool. Here’s what I’m trying to do:

Renoise has some audio tracks playing internal samples and some MIDI tracks playing external gear. When Renoise is running on its own, everything runs in time and sounds good. Now, I have an audio interface with multiple inputs and I want to record every single track of audio (Renoise and outboard) simultaneously into Reaper.

Enter Reaper. Reaper is set to master, Renoise to slave. I have configured Rewire so that I get each internal Renoise channel coming in on its own Reaper channel. All good so far. Then I add a track in Reaper that records from one of the audio interface inputs. Now when I hit play, the outboard synth is wildly out of time with Renoise’s internal audio. Renoise seems to trigger the MIDI much earlier than it triggers the samples, as if it’s trying to compensate for some non-existent delay.

When looking at the pattern editor in Renoise, it looks like it immediately jumps 3-4 rows down when hitting play.

I can’t figure out what’s going on here. I’ve tried disabling all latency-compensating settings in Renoise (Audio/Device Settings/Automatically Compensate Latencies, Audio/Automatic PDC/Enable Automatic Plugin Delay Compensation, MIDI/Compensate Latencies) but nothing makes a difference. Does anyone understand what’s happening here?


Hi sharevari,

I have the same problem with Reaper. I’m on a Mac, running through an audio interface and Renoise as master handles everything amazingly. I get extremely low latency, and everything is perfectly in sync, including any slaves.

When I run through Reaper as master, Renoise has a delay of probably 100ms or more, the waveform displays all run slowly, and nothing times up well when recording. I tried playing with all of the latency and sample-rate controls as well. I’m not using MIDI, so I can’t comment on that. Anyway, I gave up on Reaper and am trying out Live to see how it pairs with Renoise.

However, it sounds like you have a finished song and just want to spit out the tracks to Reaper to work with. If you ‘Render To Disk’ there is the option to save each track into a separate file. You could then load them into Reaper. That might be a work-around for now.

I hope you find a good solution.

Thanks for the feedback.

I realised it’s not such a big deal after all, as I can just feed the track into Reaper in two passes and everything is fine. First I record the outboard gear, and then I Rewire all the internal Renoise tracks and line them up afterwards in Reaper. This works fine. Would be nice to be able to do it in one go though.

Fortunately I don’t have your problems with syncing in general. I’m on Windows though. Sorry to not be of more help.

Oh, and Render to Disk only works for VSTs, not for MIDI.

Have you tried compensating the MIDI tracks latency as well? (making the track latency negative or positive) with PDC toggled off.
You might be able to manually compensate the specific midi tracks better this way.

Yes, I should have mentioned this. From the very start, I had the MIDI tracks at -25ms or so to get everything synced. I tried tweaking this with Reaper present but the latency introduced is a bit higher than 100ms so it was not enough.

Ah, that’s a bummer. Manual track latency compensation won’t go beyond 100ms.
MIDI unfortunately has higher delays than internal system gear though…

I had some problem with reaper stuttering the very first rows when i hit play. It seems like i solved it in reaper preferences / audio / midi devices and untick all three options on “On stop/play…”