Renoise + Reaper Routing/Crackling Issues

ok next
renoise as master again reaper as slave
I piped different reaper audio busses to renoise ( each their own rewire channel )
I applied a ringmod.effect on one of the busses in renoise …and automated the on/off state
Some strange ringmod.noise appeared …then while deleting the effect the artifacts where still audible …
Then even stranger …when switching views between renoise and reaper…pressing playback in reaper was fine…switching back to renoise …again that distorted ringmod effectsound appeared ( wchich was deleted from the mixerbus ages ago )
Verry strange indeed

O.k I reloaded the song and it’s totally fucked up …
Agaiin same configuration as above …pressing playback from within renoise is distorted ass hell , from within reaper it’s ok ( slave)
Is there a limit on how many rewire instances to use ?( I mean for routing audiotracks from reaper to renoise , not as separate rewire slaves
If I got 8 audio tracks in reaper …You have to load 8 rewire instances for separate buss routings right ?

I disabled multicore support , changed buffersize ( edirol ua 25 )…no succes
The distortion doesn’t go away …and is only there when renoise is focused

I saved multiple instances …quit funny that this all happened because I was automating the on/off state of the ring mod effect

Hi gentleclockdivider,

I have split your bug report from the compatibility list.

When posting a bug report, either create a new thread or append to an existing bug report.

Replying to the sticky makes it difficult to track (because maybe a bunch of others will follow and everything will get mixed up).

As best we can, we want to resolve these issues durring the beta. The more meticulous and detailed you are the more helpful it is for everyone involved.


I can only conclude that there is aHUGE difference fromwhich application you press playback ( renoise/reaper combo …dunno about the others )…Like I said before , Renoise pressing play =still distortion ,sometimes for minutes
Reaper presing play =o.k.

I partly tracked down the problem …for those familiar with reaper …the problem occurs when assigning the rewire outputs ( or buss routings) in the audio routing matrix in reaper …when routing an audiotrack to channel 9/10 ( or any other channel )…then set the rewire input channel in renoise to same channel …=distortion …but then only when pressing playback from within renoise …
I go to sleep now :)

Apart from that, which we have to take a look at to see if this is a Reaper problem or a Renoise problem, Reaper unfortunately can not really be recommended as reliable ReWire Slave nor Master. Please see the pinned compatibility list for details.
I think we can change that by nagging about all this in the reaper forums ;)

Define difference between 'nagging ’ and 'bug reports ’ <_<
On the reaper forum board the’y ll probably say the same thing ’ go nagging on the renoise board 'NIce attitude from a programmers view …with alll the respect , this is a beta release and I try to report bugs …How the f… should I know which program is responsible for this behaviour .
Otherwise …great update …love renoise … :D

AH well bloody rewire thing …more problems than joy
Now I really go to sleep

Nah dude, you misunderstood.

If you read the Compatibility FAQ you will see:

We (alpha testers, developers) have been testing this for months and found the same problems as you. Your help is appreciated, but you have to focus a bit more, and not duplicate our efforts.

We’re encouraging you to analyze the problem and compare it to other situations (i.e. Repear isn’t the only host out there, but is one of the few with KNOWN issues as seen in that HUGE COMPATIBLY list)

So yeah, DO nag the other forum. It wasn’t any disrespect, it was a call to arms to Reaper users. We couldn’t do this during alpha testing, otherwise the secret(s) of 2.1 would be revealed. Now in BETA is the time to do it.

Good times.

I’ve tried this here, but unfortunately can not replicate this. Which version of Reaper are you running? Does this always happen when starting playback from Renoise or just sometimes?

Here is what I’ve done:

  • Lauch Renoise, add a “#ReWire-In Device”, select Reaper
  • Reaper Starts. Create an empty track there, load a long WAV into it, then ckick on IO and add ReWire Channel 9/10 as output
  • Opened the routing matrix and removed the tracks routing to the master
  • Back to Renoise , selecting Channel 9/10 in the “#ReWire-In Device”

-> Start/stopping from wither Renoise or Reaper seems to work fine and also sounds just fine

Would be great if you could provide a small test song for this: a Renoise file & Reaper file. This way we can easily replicate this here.

reaper 2.58

Yep …like you described …pressing playback in renois still distorts (
You neeed the free plugin sq8l ,or use any other with reeaper 1.1.xrns

OMFG…I am with stupid :blink: :blink: :panic: …really …I was using windows direct sound driver instead of asio
Sorry …but hey it was very late at night …And wasn’t really focused
Sorry sorry sorry sorry
problem solved B)

Could you, to be sure, also post the Reaper Song file?

Also if that was some Audio Setup trouble, I don’t really understand what this has to do with routing and why this changed when either starting from Renoise or Reaper. Would be great if we could clear this.

That still remains a mystery to me , There was just one vsti track playing in reaper …routed to rewire channel 9/10…verry cpu friendly …
The problem still occurs when rendering …but at least I can use renoise’s transport bar .
Doesn’t reaper automatically start up when you load renoise ? , the reaper upload is a poor 0.0 mb ( just one midi track …) with renoise1.1.RPP