Renoise WITHOUT Rewire

Hi. I would like to use Renoise without Rewire.

I’ve experienced bugs developing plugins due to Rewire incompatibility.
I don’t want to install the Renoise Rewire.

As of right now every time I open Renoise I just skip the install; is there a more permanent way to supersede this step?

Again, I DO NOT want to use Rewire w Renoise.

Thanks!

Are you getting a prompt to install rewire every time you open an already installed Renoise?

Hi James,

That’s correct. Renoise is installed on my machine, located in a folder within my applications folder.

each time I open it, I get a prompt to install rewire, and I refuse it.

I do not want to install the Renoise rewire.
It has caused me problems developing plugins.
Abelton Live doesn’t like it.

If you are on Win, run regedit as admin and rename or remove HKEY_LOCAL_MACHINE\SOFTWARE\Propellerhead Software\ReWire\Renoise, restart Renoise.

Edit: Maybe you can rename or remove c:\Program Files\Renoise\ReWire Engine.dll file as well.

on a Mac. Using OS 10.15.6.

Great suggestion, as always Windows allows for more flexibility w the OS. Not really an option for me, and I’m hesitant to do anything too extreme like a sudo command in terminal.

I’m honestly surprised that it’s not something that’s just an option in the Preferences
“Do Not use ReWire”

I’ve heard that ReWire might be deprecated. Is this true?

Have you checked these comments?

Unfortunately, yes, it looks like ReWire is deprecated by Reason Studios (Propellerhead)
“Reason 11 and later does NOT feature ReWire, since you can use Reason 11 as a Rack Plugin in a compatible host DAW.”

But still ReWire is very useful interface/connection and there is no full alternate. Fortunately, @taktik wants to still support it. Why to stop something that can help…

I don´t think there should be an option for Rewire in Renoise. Maybe I am wrong, I don´t know details but as far as I know Rewire is “just” interface that is registered in the OS system. Renoise installer “just” register its rewire dll (on Win using system registry key) and other apps like Ableton can use it or not…

What exactly is the problem here?

There is no option to disable ReWire in Renoise, so it may be easier to solve this problem instead.

Reason Studios, formerly Propellerheads, has fully dropped support for ReWire. I asked if it could be open sourced because there is no equivalent available yet. Let’s just say, don’t count on it. So there’s a final build that will eventually get broken by a Microsoft update, and that’ll be that. A new equivalent will then slowly take root.

Every time I open Renoise now it requires that I sign in to access rewire. Such a weird bug.

Yup. Same here. Renoise asks each time it starts to authorize Rewire installation. But I DON’T WANT REWIRE. I have also Reason, so if I want to use Reason I just use this monster as it is. ReWire is shit. And since Renoise 3.3.2 update I’m a little done with Renoise because of the bug which eternally asks me to install ReWire…

What happen if you delete the REWIRE DLL in the renoise folder?

I use Mac (not Windows, which has DLLs). I found that Renoise creates alias in the Library … Rewire folder. But the alias is broken. Even if I create proper alias manually (to the Rewire bundle destination „RenoiseRewireDevice.bundle” inside of Renoise app package) then it still asks to authorize ReWire Engine installation on every run… This must be a bug, because it was not in version 3.3.1 (now it is in 3.3.2). … Best of all, again: I don’t need ReWire at all. Having Reason 11 I can use it just as AudioUnit (or VST) plugin in any DAW (including Renoise)… ReWire is dead feature.

REWIRE is not dead for everyone

Tracktion+renoise in my case

With “rack” in tracktion,I can do good things

Renoise+Tracktion= RecKtion🙂

I’m having the same issue. This happens every time I open Renoise, and it just started from the time I updated to the newest version of Renoise. Any way to disable this please?
image

[OK! SOLVED]: Delete Renoise from the Applications. Just download package (3.3.2) from your account on the Renoise website and add as „a fresh new app”. In shorter words: to upgrade Renoise just delete old instance from Applications, then download new version and add to the Applications. It will ask only once to install ReWire then.