Rescanning midi devices constantly v3.1


(DerekJDB) #1

I’m pretty sure it never used to do this but lately it’s become utterly unusable as I can’t do much for it pausing every other minute to rescan midi devices.

Any ideas as to why?

PS I’m on a windows 7 machine and not a laptop. M audio delta soundcard. Should that matter…


(gentleclockdivider) #2

I have the same issue , but it doesn’t happen all the time
Mostly when I lower/close my laptop screen ( I have an external monitor connected ) ,


(Raul (ulneiz)) #3

I’m pretty sure it never used to do this but lately it’s become utterly unusable as I can’t do much for it pausing every other minute to rescan midi devices.

Any ideas as to why?

PS I’m on a windows 7 machine and not a laptop. M audio delta soundcard. Should that matter…

I can only think of the following:

  • Go to: Renoise:Preferences/MIDI: “Auto-rescan” when hot-plugging devices".Is this checkbox enabled?

Is it possible that you have a bad connection with the USB cable or the USB connection ports? Are they loose, dirty, that can cause a bad connection?

Maybe in this scenario Renoise rescans the devices that are reconnected. Review the USB ports and the USB cables you use.It could be a very subtle connection failure. It could even be an internal failure of your MIDI device.

Make tests. If necessary, uncheck the checkbox…With the box enabled you should not have problems, unless Renoise contains a related bug.

You should mention your connected MIDI devices, your motherboard model. Maybe someone with more experience knows how to help you.Personally I recommend you use the rear ports of the motherboard, not front extensions. It also uses the original cables, not additional USB cable extensions.


(James Britt / Neurogami) #4

A while back I would occasionally have a USB issue with some code I wrote. A device that was recognized for a while would suddenly seem disconnected.

I found a tool that will show USB log activity

https://www.nirsoft.net/utils/usb_log_view.html

It might help find out if a USB MIDI device is getting disconnected/reconnected.

I never seem to have enough USB ports so I added a USB controller, plus my monitor is a USB controller, and honestly they can get flaky as they all use different drivers and such.


(DerekJDB) #5

With regard to having dodgy cables. I don’t have any connected. I’ll try switching off auto rescan. Cheers!