Rewire Issues + Renoise Super Slow To Load Song.

Hello everybody.

After understanding that my precious routing secondary input into audio-plugins is dead for now and that I’ll have to wait for an hypothetical implementation by the Devs (I pray for it everynight before falling asleep). I tried to achieve in by another way,

I wanted to rewire Renoise as a slave int Reaper 64. That way I could use best of both world : the tracking and robustness from renoise, and the routing and 64 bit processing (for mastering) from Reaper.

Sadly I ran against many problems. First the host32 reaper module kept crashing like a mad… So I was about to forgive but I tried 32 bit version just to see.
And bingo it worked. But then another problem arised, sync problem and sometimes crashes anyway, plus I can get the benefits of 64 bits processing…

So I tried anyway to load my track into renoise and start tweaking. But I had to forget that idea because it never loads the track. Staying stuck at loading forever.

Even while not using rewire at all, Renoise sometimes take soooooo long to load a simple track (a few samples, and patterns).

I don’t know what to do. Reinstall windows or leave music making for ever. I feel really bad theses days coz nothing is working right.

Maybe I should have posted on reaper forum, but I’m not a registerd user yet and anyway I wanted to take a look here, see if someone has the same problems.

Thank u already for any help or comment.

Bye.

‘Even while not using rewire at all, Renoise sometimes take soooooo long to load a simple track (a few samples, and patterns).’

This makes me believe there is something wrong with your system, Renoise shouldn’t take long to load a simple track with a few samples.

I think but I just bought a fresh comp to make music…

So I guess windows is the problem.

I’m cursed to reinstall it all

and if it doesn’t work i can buy a new comp maybe

before ditching windows or going mental or whatever, first answer a couple of simple questions so people can actually try and help you out:

  • which version of windows do you use?
  • what hardware are you on?
  • is your computer slow only with Renoise, or at other times as well?
  • when you open up the task manager in windows, and you load the song which takes a long time to load, do you see a CPU spike or high RAM use or whatever? do you see Renoise using that are is there other software using up too much stuff?
  • do you have Renoise still rewired into Reaper when you try and open up that song? or is it Renoise only?

Reaper 32-bit doesn’t load 64-bit plugins… it loads 32-bit plugins unless they have implemented some mechanism like JBridge.

ReWire has currently no 64-bit engine in any host.
The way some hosts using ReWire in 64-bit mode is by doing some wrapper technique, but this part seems very buggy in Reaper (Reaper supposed to allow ReWire support in their 64-bit host using witchcraft).

Sorry I always forget to talk about the tech details.

My specs :

  • Windows 7 64bit Home
  • i7 @2.8 Ghz
  • 8 Gb ram
  • M-Audio Ozone as soundcard (sadly I use directX driver for now coz if not I can’t control volume :( )
  • OS disk is a Intel SSD
  • data disks are raid 1 on western digital disks
  • have comodo internet security installed
  • as well as VMware
  • a lot of audio appz
  • some games
  • internet stuff (firefox, pidgin, skype, etc…)

Renoise seems stuck while “initializing direct midi”, then finally load. then sometimes, when I load the song, it’s really slow. Especially after renoise stuck on direct midi init.

When I do a fresh reboot, sometimes it’s ok, sometimes not.

Reaper 64 was crashing with rewire at first time.
Reaper 32 was running with rewire, but then problem appears -> tempo problem, can’t load my song.
After running with 32, I could run 64 but same problems appears.
After that, can’t run again with 64, crashes direct.

Except that sometimes renoise says some vst are crashing, other times it removes vst from the list of good vst but these vst i used for years (with older version of renoise demo as well), never had a problem.

sometimes when I open my song, the sound is buggy, i need to delete vst fx and put it again with same parameters.

This happens with many songs, using different vsts.

My comp is acting weird. Sometimes really fast, sometimes too slow, especially with music. Some games are slow too while others are speedy.

When renoise hangs like this, cpu is almost at 0% usage. disk also and ram is about 2.5/8 Gb so I think it’s ok.

Thanks for ur help anyway ;)

I read something about that.
But I tried rewire reaper 64 with reason and there’s no problem, everything runs fine (except that reason take also sooooo long to load a song, i ran benchmarks on disks and they are really fast, again no cpu usage is noticed).

I don’t try to load 64 bits plugs into 32 bits host, more the opposite.

Thanks for ur advice.

PS : I looked into system to see what programs are running and I think I saw nothing weird, no malwares or something. But I’m not expert in windows services so maybe it’s hidden here. Anyway no noticeable cpu activity.

from the sound of it, i’d side with TheBellows and diagnose this more of a PC issue than a Renoise issue. i’m no expert either though, but i’d start looking at the config of my PC before doubting Renoise. in my experience, Renoise has always been fast as hell, and pretty light on system resources.

I agree but what do I have to fix in windows ?

I don’t think the hardware is the problem coz it works really fast (normal ?) sometimes, especially after reboot.

The rewire sync has problem most of the time I agree, but with renoise only.

What could be so OS dependant that it produce this strange behavior ?

Maybe this week end i’ll buff myself up, and start a fresh install… This time only with audio, antir vir and VM

All the crap will be installed on VM (games internet utilities etc)

I’m not sure though… Maybe I should have 2 comps.

Give us the XRNS and we may try to load it into renoise on our machines?

i’m not sure either, i’m no computer expert by any means. it depends on how long you have had your system running, and how much stuff you’ve installed, p0rn you’ve downloaded etc. if i were you, i’d start with running some software like CCleaner to clean needless crap off your system, and Defraggler to do some disk defragmentation (both great programs and available here: http://www.piriform.com/download)
you can use CCleaner to check out your startup-programs as well i think, you might want to go through those to find out what stuff is running on your computer at startup.

also, i never used VMware before, but i think i read about how it can use up a lot of system resources (which makes sense, because it has to emulate a 2nd system onto the one you are already running, so you are running 2 systems at the same time, essentially), so you might want to try switching that one off?

come to think of it, have you tried just quitting all other software (that you do not need to have open) and running Renoise?

Maybe your soundcard isn’t good enough? Just guessing here, but i noticed a huge improvement when switching from my on board sound card to E-MU 1616m.
Renoise with a few samples has never been a problem though and it’s very strange if your PC is new.
If you have added a sound card after buying the PC then it could be hardware conflicts, which hopefully a reformat and fresh installation of Windows can solve. You can also try to move your card physically from one PCI slot to another, that may help sometimes.
Only suggesting though, i’m no expert, but i’ve had my share of computer problems.

would be strange imo. my laptop is 4/5 years old and i just use my simple on-board soundcard and it works like a charm.

i was thinking: you could also try disabling the VSTs (Edit > Preferences > Plug/Misc > uncheck the VST box). maybe you have a VST that fucks things up?

I don’t have it with me right now.

But it happens with almost all my xrns (if not all, i tried a lot)

About VMware, normally I don’t run any instance of VMware when I try to compose a song. But I talked about it coz I saw that this install was more than just files copied on disk and a few registry entries created/modified. VMWare installs low-level drivers, services running in background, and I don’t know what else.

I’m still looking for a safe way to use full potential of windows (trying new programs, install crappy progz, games and whatever, internet crap, office crap, development crap, cleaning utilities crap) without crippling it. With VMware I thought to find the grail, another Windows that I can run beside mine, and which I can be bad with. Keeping my audio install fresh and clear. Maybe I should try with sandboxie… But I saw it runs a service too.

Is someone has a cool link with a list of essential Windows services, to know what I could disable while keeping full power for music ? :D

I thought about this… The Ozone is old, uses a USB 1.0 port if I don’t mislead myself, with drivers sometimes unstable (for instance I can’t do 24 bit - 48000Hz, I got a lot of artifacts, I have to stuck on 44100Hz, I think 16 is more compliant but I switched long time ago, if I use 16 bits then my realtek is enough. Others times ASIO driver die and I have to switch to DirectX then back to ASIO, or restart soundcard, or reboot comp).

I should try loading the same setup with my integrated sound card to see if the problem arise again.

Thanks a lot for all the good ideas I got here, I’ll continue my investigation. The path to music is hard :D especially when u can’t even output a sound, tech problems are annoying :P

USB1 sounds very old and slow to me, but i don’t know how these things work :rolleyes:

Definitely a good idea to start with the bare essentials. This would include disabling plugins, tools in Renoise.

Heard about that… Even it seems weird to me but maybe it’s true :P I should do some research.

Mmmh I wonder if someone did it already…

I mean running Reaper 64 (the only 64 DAW, correct me if i make a mistake) in sync with renoise through rewire ?

If someone is using that config (with plenty of plugs) and has no or few problems, I would like to know.

Oh, I forgot, for information : Renoise stay stuck while “activating song” the lasts times I tried to rewire.

I did a lot of tests theses last days with a lot of demos (thus crippling more my windows, but I don’t care anything anymore now…)

And everything (not everything but a bunch of well-known names) runs quite stable with rewire and reaper 64 (even Orion :o !), except renoise :(

I wonder if there is maybe something involved with the way time are handled in renoise.

I loaded a factory song (the keith303’s one, love it :D) and it worked as long as I didn’t tried to change play position while playback, then it crashed (the host).
Plus this is super-boring, renoise sees that the link with the host is broken, and it steal the audio driver from reaper… It should ask me what to do instead (do you want to : take the hand, close, stay like this)

load a song that uses any vst send my comp in the endless loop of “activating song”.

and rewire engine is broken, i have to restart it all, to reproduce endlessly the bug.

I’m sad, I just bought Renoise, but seems I will use it as a drummachine, or maybe not use it at all.

Nobody did wrong but me to think everything was ready for me… No luck coz I still love this interface. But I need to make music, not to like a sweet graphic interface or to stay stuck with bugs… I hope to come back soon but for now I lost too much time already, two weeks i try to make it working, and I’m too tired to reinstall windows.

@Davias: i’m sorry you have to go through all that. this is not supposed to happen, and as many already noted before, you may be the only one experiencing this.

seeing how there are no more suggestions (for now at least?) - i’d suggest trying Renoise on a different computer to see if the problem happens there as well. it should not. you would then at least know Renoise is not the problem, but your computer is. or maybe it would be better to say ‘the combination of Renoise with your computer’.

I agree with you, but for now I need to produce something, maybe I’ll try again while changing soundcard, reinstall windows and all the stuff…

Thanks for your support !