Rewire Renoise Midi To Ableton

I want to use ReWire to send MIDI notes from Renoise (Slave) to Ableton (Master) and to Reaper (Master).
After reading this I have only managed to send audio out to those programs.
I’m a registered user, so I have no ReWire limitations.
Thanks.

ReWire slaves can only send audio to the master. It does not work the other way round as it does with Midi.

Is there a work around? Maybe to set Renoise to send MIDI out to a channel that can be listened by Ableton?
The simplest solution I’ve been able to come with, is to install the tool that lets you save MIDI files from Renoise. Works well enough for me.

Oowh sorry, overread the midi option, Well, a virtual midi cable should also do the trick, pick a port inside Renoise, then connect it to another port and configure that midi device in the master application.

I always used MidiYoke to do things like this. It’s a virtual MIDI server that runs on Windows and it allows you to share MIDI streams between applications. It’s pretty useful.

Dear All,

i want the same, because i have VSTi or 32 bit VST that not anymore work with Live 9.
So want to connect Renoise as Slave and Ableton as Master.
For me it is not clear what i read above how to do it get the Midi Data.
I’m on Mac.

One think more, i installed the IAC Driver:

I can see this in Ableton but not in Renoise!

Thank you forn answer.

regards,

waldemaR

Maybe this helps:
http://www.scene.org/~esa/renoise/#live

It should work for current versions also.

Dear Thilo,

now we here with a other conversation :wink:

No, sorry this not helps, because i want send Midi Data.
And this only allow to send Audio Data.

But thank you anyway. Their must be a solution, hopefully.

regards,

waldemaR

Midi routing from VST plugins is currently not supported at all (neither within Renoise).
The other way around: If you want to control several instruments from the master, use the IAC driver to setup several virtual channels and then assign these virtual midi busses directly at the Midi in of the instrument:
http://tutorials.ren…ings#MIDI_Input

I’m trying to do almost same. I’ve just loaded bunch of arp vsts (Cthulhu, Bluearp etc) into Reaper/Ableton and send arpeggiated midi data via virtual cable back to Renoise. Next big step is trying to sync both hosts to Renoise. It seems to be easier said than done.

Dear vV,

thank you for the reply and help.
I will look into this. And of course if i have a question i will come over to you once again ,-)

regards,

waldemaR

Dear Jesseri,

this works fine?
Maybe this will be another way for me.
i’m looking in the moment to start arp vst, kirnu cream in Ableton to send the arpeggiated midi data via virtual cable back to Renoise where my Sylenth 1 waitng for.
do you have maybe something for me where i can started easily, thank you!!!

regards,

waldemaR

Yes and no. I can’t get neither DAWs to sync with Renoise. Ableton has definately more promise in that department. It gets correct tempo from midi clock, but when EXT sync is on, trying to play with the keyboard notes cuts off immediately and arpeggiator doesn’t work. When EXT is off arpeggiator works, but sync is off. I’ve tried to use my Fantom G7 as a midi clock master but Ableton won’t sync to it either.

Current setup:

I’m using LoopMIDI program for virtual midi ports. Made couple virtual midi ports (LoopMIDI1 and LoopMIDI2) LoopMIDI1 for sync and LoopMIDI2 for Midi output from arpeggiator. LoopBe1 doesn’t seem to work correctly on my Windows 8 computer.

Renoise and Ableton not ReWired together

Renoise preferences: Midi -> Midi clock master : LoopMIDI1 (sync midi port), Send clock and Send MMC selected
Ableton preferences: Midi -> input LoopMIDI1 port: Track and Sync On (Midi clock sync delay 0ms, sync type MIDI Clock, mtc frame rate 30fps, mtc start offset 00:00:00:00). Side note, these options are hidden. Pressing the triangle on the left from input text, will show these options.

output -> LoopMIDI2 track on (this port sends arp midi to renoise)

On Ableton:
(i’m using cthulhu)

Track 1. Cthulhu -> Midi from: Fantom G. All channels. Track needs to be armed
Track 2. Midi track -> Midi from: 1-Cthulhu, Cthulhu x64. Midi to: LoopMIDI2, Ch.1. Track needs to be armed also.

On Renoise:

Current instrument settings:
Midi input : Device -> LoopMIDI2. That’s it.

Cheers,
Jesseri

Dear Jesseri,

thank you very much for the details.
I will try this in a silent moment.

regards,

waldemaR