Rewire With Reason


I’m a big Reason fan since version 1.5. With version 5 (including Record 1.5, also from Propellerhead) & planning to do more live with Reason I was looking for a rewire-host which could make my set-up more flexible (without changing from Reason to Ableton’s Live, don’t get me wrong, Live is an amazing app but Reason’s GUI is more my cup of tea). In Renoise I found the tool to master & control not only Reason/Record but also guitar-amp-modelers (mainly PRG change) & midi controlled video-apps.

So far the introduction, the reason I’m posting is that after I upgraded to Renoise 2.6 as soon as it had turned gold I noted that rewire didn’t work properly. First I tried to open a song which I had already made in Renoise 2.5.1 but it couldn’t recognise the rewire-devices. But also creating a new song & trying rewire set-up was futile. After closing Renoise I discoverd that Reason couldn’t start due to Rewire issues, even after I restarted my MacBook Pro.

Pretty soon I discovered that the renoise.rewire file was from the same date as the rewire.bundle file (for Mac in the folder: Library/Application Support/Propellerhead Software/Rewire). So what I did was starting Time-Machine for my latest back-up prior to the last Renoise install, put the rewire.bundle file back in place and everything was working like a charm again within less then 10 seconds. A reinstall of Reason probably could have done the trick as well but this fix saved me the (re)installing time.

Maybe this post will help other Reason-Record-Renoise freaks like me, cheers.

Have a look at this thread.

Sure I’ve read other reports of having to uninstall and reinstall to get working. Something to do with the Rewire driver not liking two versions of the same software iirc.

Thnx kazakore for sharing the thread. Issues seems similar & sure it’s a rewire-issue & apparently the rewire.bundle was overwritten when I installed the latest stable release of Renoise (2.6 that is). So reinstalling Reason probably would’ve worked as well assuming all Reason dedicated rewire files would be reinstalled as well. But I simply stated my fix/solution 'cause I can imagine others puzzling with this & by ‘resetting’ the ‘rewire.bundle’ with Time-Machine, saved me the time reinstalling & tweaking Reason.