[Solved] No Rewire Between Logic And Renoise


I’ve just downloaded the new renoise beta (b6 at time of writing) and now i can no longer get Rewire to work.

with b5 i could just start up Logic and Renoise would ask if i wanted it to become slave, but now this no longer happens.

have i overlooked something?


Do you start Logic first? The rewire master should always be started first… It works fine for me. Which version of Logic do you use? I have Logic 9.1.1 on OSX 10.5.8…


Thanks for your reply. Yeah i have Logic 9.1.1 on OSX 10.6.4, and Renoise Beta 6… Is there something i can do to reset the Rewire scan? it just doesnt seem to think Logic has been started up first.

If this used to work but now out of a sudden does not longer, then restarting OSX and trying again sometimes does magic with ReWire. Have you tried this already?

Also make sure you’ve allowed registering Renoise 2.6 as ReWire slave. This can be done by first starting Renoise standalone and entering your password to allow ReWire installation.

ok thanks Taktik i’ll give that a try

ok i discovered the problem. Starting Logic 9 in 64 bit mode won’t allow rewire to work (and incidentally wouldnt verify some AU plugins i had installed either)

thanks for everyones help.

I have a similar problem to this - except with Cubase rather than Logic - so thought I’d resurrect this thread rather than start a new one. I’m a registered Renoise user and my setup is as follows:

Windows 7 64 bit
Cubase 5 (running in 32 bit) as ReWire Master
Renoise 2.6.0 RC1 as ReWire Slave
I also have the final version of Renoise 2.5.0 installed

My problem is the Renoise 2.6.0 RC1 doesn’t detect Cubase as a ReWire master on startup. If I try with everything else as is but launch 2.5.0 instead it detects as expected, and I’m sure it worked fine on the last beta I used too (beta 6, I think), so it seems to be a new problem.

I’ve tried Taktik’s suggesting of restarting my system but to no avail. I’m not sure what was meant about making sure that I’ve “allowed registering Renoise 2.6 as ReWire slave”: I’ve opened it in standalone but don’t see anywhere to enter a password (besides, I’ve downloaded it from the backstage and I thought we didn’t need to enter passwords or anything?).

Anyway, I really hope someone can help with this, I use ReWire a lot and I’m really liking 2.6.0 so it’d be great to get them playing together again!


Sorry to bump this but… anyone? The problem persists with RC2. Oddly it will detect Ableton Live as a master but not Cubase - even though Renoise 2.5 will detect the same instance of Cubase quite happily. Incidentally, the problem persists regardless of whether the Renoise rewire channels have been activated in Cubase. Any help would be greatly appreciated.

Probably not helpful, but i’ll give it a shot anyway.

On OSX there’s a single Rewire library for all installed versions. If I run 2.5, i get asked for the root password to install it. If I switch the 2.6, the same happens again. Files for all ReWire enabled software are located in: /Library/Application Support/Propellerhead Software/ReWire

I don’t know how ReWire on Windows works, but I imagine it’s the same principle. If you have two Renoise versions, only one rewire will be registered at a time, most likely the last installed? (This could be completely wrong, though, I don’t know Windows anymore)

Also, on Windows 7, theres something called UAC now. From the few threads I have read, this affects certain plugins. That is, you need to be “root” while installing, or it won’t work. Example problem here.

All this to say, maybe check for user permission issues?

Thanks Conner_Bw, you’re a legend. I haven’t tested systematically to find out exactly where the problem was, but uninstalling Renoise, reinstalling whilst running as an admin, and then making sure that both Cubase and Renoise were being launched with admin rights makes it work. I must admit that I’m surprised that this worked and I’m kicking myself for not trying it earlier, but I’m very happy that it’s working. Thanks again!