Ringmod in sampler modulation when loading older tracks won't produce any sound - renoise 3.4.1-3.4.2

Loading older tracks, legacy ringmod in sampler modulation won’t produce any sound, it is still working with earlier versions 3.3.1.

1 Like

The user will get a quick volume on/off effect. The internal LFO on the Sampler only goes 20 Hz.

If using an LFO outside of the Sampler to modulate the volume, it still only goes 20 Hz. But, one can work around this by actually drawing in more cycles on the LFO in this case, thusly getting an AM effect, because more cycles have been drawn. It’s not quite the same.

@migloJE, it would be nice to see a screenshot of what you’re describing - I am unaware of the actual ringmod device not working in the latest version of Renoise. It works fine for me in

Renoise v3.4.2, 64 bit
Mac OS X

One other thing that might help, and this may be a long shot - the old devices can be uncovered via this Tool:

1 Like

I would not complain if the effect would be the same with the “am sine” after the upgrade, but actualy renoise used to load legacy instrument settings correctly, now it just don’t produce any sound when you load it, it worked in earlier version…

Usualy when loading old tracks (and i have alot of them) when i want to finish them in new renoise version i dont upgrade instruments to keep all the settings working. But in new renoise 3.4.1 and 3.4.2 legacy settings produce no sound.

@migloJE AM Sine can be located in the Flanger, and the Flanger can be turned off.

it’s not about the workaround its about legacy support. Program shows that it recognize the old fx but it wont work, it worked in 3.3.1 version.

1 Like

I see what you mean - that picture shared a lot more information!

This does sound like an issue worth alerting @taktik about - I’m putting in their handle here. It’s important!

@taktik Here is comparison of 3.3.1 version and 3.4.1 loading legacy instrument.

1 Like

Gotcha - maybe tag @taktik to let them know. Otherwise, well, it’s kinda like talking into a well :slight_smile: Thanks for sharing the photo and the video.