Rubberband Updated (3.0)


(Jon Heal) #21

Should the Rubberband Tool show up as an item in the Tools menu? It doesn’t currently, although if I select Tools | Tool Browser …, I see it there.


(dblue) #22

It shows up in the Sample Editor context menu.

As it says on the tool page

:)


(Jon Heal) #23

Okay, thanks. I guess maybe I’ll try to actually read next time. :blush:

It took me a while to find the Process submenu … I’m still not quite used to right-clicking for everything. ;)

… and now that I re-read your post, I see you specifically say “context,” so I am a real knucklehead.


(dblue) #24

No worries at all. But, yeah… definitely get into the habit of opening the context menus for different parts of Renoise. There’s a lot of useful functionality you may simply miss otherwise. When you’re stuck on something, the answer is often right there under your mouse cursor just waiting to be discovered.


(Mane) #25

I’ve got this problem and I’m on OS X 10.5 as well. So is the only way to fix it to upgrade to Snow Leopard?? :(


(Suva) #26

It’s supposedly possible to fix it by downgrading the rubberband executable to some version. Not sure which version exactly and whether or not it is compatible with the tool itself.


(Mane) #27

Yeah I had an old version of the tool and that didn’t work either. :( Do you have to install this library for it to work? http://breakfastquay.com/rubberband/index.html


(Cas) #28

Awesome tool. will have to get used to rubberband but what I hear from it now (tried on one whole sample), good results! Thanks!


(Elrinth) #29

would be awesome if this tool was updated for newer versions of renoise.


(odoyle) #30

I’m with Elrinth. Can we get a new version please? (or Rubberband support natively, cough cough)


(thalamus) #31

Hopefully we’ll see a deluge of updates for tools once Renoise v3.0 is released.


(odoyle) #32

Thank you, Suva!

I can’t believe how fast you fixed this, btw.


(thalamus) #33

??


(Tom de Rooy) #34

Not fixed, but just updated.


(Suva) #35

Is there something broken I don’t know of? Other than the macos issue, which I can’t really fix.


(capitán kazoo) #36

just tried your tool on some breaks and it worked/sounded great! thanks for making rubberband available for renoise! (if i already said thanks in this thread, no problem, you deserve a second one :) )


(EatMe) #37

Hello, I need some instructions on where to put the downloaded

“libsndfile-1.dll”

or the

“rubberband.exe”

on windows

to work with this tool


(LOLFAIL) #38

hmm there is no such things, download tool, doble click on it and thats it, to work with it - right click in sample editor


(EatMe) #39

Oh hm that’s right it already works.

Maybe there should be a note that you do not need the external rubberband download for windows.

@Suva: The tool works fine here!


(Skolskoly) #40

(sorry, didn’t realise I couldn’t attach a 512K+ file. Here’s the tool!)

hey if any of you were looking for paulstretch, I’ve hacked something together with the rubberband tool. To use it you’ll need to get Python 2.7, as well as NumPy and SciPy from here.

Paulstretch will show up in the usual “process > ~timestretch” dialogue. Just toggle the “enable paulstretch” box, and adjust the three new text boxes.
I’ve only managed to get it working with 16bit samples so far, you’ll have to convert them before you process them. (otherwise you’ll just get silence.)

I mainly just did this for myself but I hope that somebody else will find it useful. or at least save them a day of monkeying around with lua. :P